SOLVED And yet another AMD Radeon Driver Query...


Bif

Joined
Oct 17, 2015
Messages
1,166
Reaction score
440
Hey all, As my specs indicate I'm running an AMD Radon 6310 and for the most part it's smooth sailing, although through no rhyme or reason very recently it's acting up on YouTube with freezing at 720p in full screen mode.
Small screen streams fine in 720 as does 480 in full screen, I've disabled Hardware Ex. but problem still persists..MS informs me that my driver is up to date although I'm wondering if maybe I should rollback to another driver?
I'm using Firefox but this happens on Chrome as well, any opinions, help and or assistance always appreciated!
Flash is up to date and I've also tried both Flash and HTML5 YouTube versions.
 
Ad

Advertisements

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
12,391
Reaction score
1,992
Sorry Bif..... not an AMD guy.
Haven't used one since back when they were still called ATI.
But, I bet there is someone here who is and might suggest a possible option or two.

As an aside, I've never been one to chase the latest and greatest driver except in cases where I was experiencing some difficulties that a change in driver might address.
AND
I've never been hesitant about rolling back a driver if I thought it might help.

NOTE: When it comes to display drivers it's not always easy to get rid of old remnants so I use Display Driver Uninstaller from here.
Run it in Safe Mode, using the default / recommended choices
http://www.wagnardmobile.com/DDU/download/DDU v17.0.2.1.exe

That way I know I have at least some fighting chance of avoiding any conflicts.
 

Bif

Joined
Oct 17, 2015
Messages
1,166
Reaction score
440
Thanks Trouble, I think I'll start by rolling back the driver and see if that fixes the issue..I as you don't like downloading the latest and greatest drivers either, will post back after backtracking the driver.
 
Ad

Advertisements

Bif

Joined
Oct 17, 2015
Messages
1,166
Reaction score
440
UPDATE:

I downloaded the AMD Uninstall utility and cleaned all the old drivers and and traces of old remnant rap off the laptop,rebooted and ran Updates where it installed what MS deemed as the best driver for my system and all seams smooth thus far.
Early days but reasonably content...
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top