SOLVED Any experts on HDMI connections ?


Joined
Nov 28, 2015
Messages
31
Reaction score
1
Have a monitor that can only be put to sleep by DVI connection and computer with WIN7.
When I connect this monitor to my other computer through HDMI cable (this HP computer has only HDMI and VGA), and put this computer (Win10) to sleep, computer goes to sleep alright but monitor does not, I have to manually shut it off.
Monitor is a high end high resolution bought in 2007 already with HDMI jack but what quality the early HDMI had ?
This is my educated guess about what is the problem.
There could be something else in play here .
I could buy adapter (HDMI to DVI ) and eliminate HDMI but would I really bypass HDMI ?
What do you guys think ?
 
Last edited:
Ad

Advertisements

Joined
Nov 28, 2015
Messages
31
Reaction score
1
Monitor sleep mode fails with HDMI connection on Win10.
 
Joined
May 6, 2015
Messages
2,416
Reaction score
375
What happens if you shutdown the computer rather than using sleep? I don't use sleep.

I have three desktops running W10 into 3 different brand monitors on HDMI

1. Shutdown computer monitor goes black with a little moving square that says HDMI and after a while just goes black.. Samsung.
2. Shutdown computer monitor displays a small thing saying check video cable for about 30 seconds, then says monitor going to sleep and goes black. Philips
3. Same as 2 HP.

Numbers 1 and 3 I then use the monitor power switch, #2 I don't bother as the power on indicator has been dead for a couple of years so it just stays on.


Not an answer but just what happens here.
 
Joined
Jul 29, 2015
Messages
237
Reaction score
56
Did it used to work?

Try a different HDMI cable.

The video signal in HDMI is the exact same as in DVI. The difference is DVI does not contain audio content nor does it contain a HDMI control channel. So if DVI works, using an adapter "should" work here.

When I connect this monitor to my other computer through HDMI cable
So just to clarify, you have tried this monitor on two computers with HDMI and it does not go to sleep with both computers? Or have you tried HDMI with only one computer? If only one, you might find a friend's HDMI computer and see what happens there. It could be your monitor's HDMI has gone bad. Or, try a different HDMI monitor on this computer. Note that many modern TVs have HDMI computer inputs.

Taking sleep mode off does not fix the problem. It just covers it up, forces your computer to burn electricity unnecessarily putting increased wear and tear on your electronics and in particular, your fan and drive motors. So fixing the problem, if possible, make more sense than pretending the problem does not exist.
 
Joined
Nov 28, 2015
Messages
31
Reaction score
1
Thank you ioetech1, Tim Locke, Digerati.
I will try to clarify this.
There is one monitor and two computers in play here.
Monitor goes to sleep on Win7 computer and DVI cable, no problem here.
Monitor does NOT go to sleep on Win10 computer and HDMI cable, instead goes to "no signal" state until I manually shut it off. Since I want to use this monitor ONLY on Win10 computer, this is a big problem.
I agree Digerati, screen saver is no solution at all.
 
Last edited:

bassfisher6522

Moderator
Joined
Sep 22, 2014
Messages
1,196
Reaction score
171
Monitor does NOT go to sleep on Win10 computer and HDMI cable
Sounds more like a driver issue with 10.....where the HDMI ports are concerned. What are your hardware specs for the PC running windows 10?
 
Joined
Jul 29, 2015
Messages
237
Reaction score
56
It could be a graphics card driver issue, I agree worth checking out. I note I had sleep problems that were due to Samsung Magician keeping my system awake - supposedly to improve performance with my SSD. I uninstalled it and no problems since.
 
Joined
May 6, 2015
Messages
2,416
Reaction score
375
I wonder if HDMI is missing a signal that DVI supports...HDMI is designed for TVs not Computer monitors and is more concerned with the copy protection handshake than it is with controlling the monitors power.
 
Joined
Jul 29, 2015
Messages
237
Reaction score
56
I wonder if HDMI is missing a signal that DVI supports...HDMI is designed for TVs not Computer monitors and is more concerned with the copy protection handshake than it is with controlling the monitors power.
Yeah, it came out of the home theater equipment world and I agree, never has worked well, IMO, with computer monitors.

It would be good to try that monitor on another HDMI computer to see if the computer is the problem or the monitor. And again, always good to try another cable too.
 
Joined
Oct 1, 2014
Messages
2,097
Reaction score
307
Just a quick question, is the monitor set for one specific input or is it allowed to search for an input. Perhaps setting it to use HDMI exclusively would make a difference.

Beyond that knowing the version of HDMI the computer uses and type of HDMI cable might allow someone to see a problem.
 
Joined
Apr 19, 2016
Messages
45
Reaction score
2
well the power manegment is in control becose if the hdd ware to go to sleep the hdmi will lose the signal so its really up to you how you want to controll it my advice is leve evrerything on hdd no power off ever and leve the pc in screen saver and just turn off the tv / monitor it will not harm anything on the pc
 
Joined
Nov 28, 2015
Messages
31
Reaction score
1
Just a quick question, is the monitor set for one specific input or is it allowed to search for an input. Perhaps setting it to use HDMI exclusively would make a difference.

Beyond that knowing the version of HDMI the computer uses and type of HDMI cable might allow someone to see a problem.
It is set exclusively to HDMI. Monitor HDMI is circa 2007 computer HDMI is circa 2015. I was always weary of HDMI for computers, Hewlett Packard much less so. I will try to find out what HDMI is there. I am very surprised that this is not a common problem.
 
Joined
Nov 28, 2015
Messages
31
Reaction score
1
It could be a graphics card driver issue, I agree worth checking out. I note I had sleep problems that were due to Samsung Magician keeping my system awake - supposedly to improve performance with my SSD. I uninstalled it and no problems since.
I deleted all crap-ware I could find, plus if computer is not sleeping I have display on the monitor.
 
Joined
Nov 28, 2015
Messages
31
Reaction score
1
well the power manegment is in control becose if the hdd ware to go to sleep the hdmi will lose the signal so its really up to you how you want to controll it my advice is leve evrerything on hdd no power off ever and leve the pc in screen saver and just turn off the tv / monitor it will not harm anything on the pc
Advice will not be taken. I want monitor on sleep and computer on sleep. Thank you joetech1 for your help.
 
Joined
Nov 28, 2015
Messages
31
Reaction score
1
I wonder if HDMI is missing a signal that DVI supports...HDMI is designed for TVs not Computer monitors and is more concerned with the copy protection handshake than it is with controlling the monitors power.
I was thinking about that too, will try to use adapter HDMI to DVI and see what happen
 
Last edited:
Joined
Nov 28, 2015
Messages
31
Reaction score
1
Sounds more like a driver issue with 10.....where the HDMI ports are concerned. What are your hardware specs for the PC running windows 10?
Tried to copy Speccy and System did not let me any other way to get it ?
 
Last edited:
Ad

Advertisements

Joined
Jul 29, 2015
Messages
237
Reaction score
56
becose if the hdd ware to go to sleep the hdmi will lose the signal
Ummm, that is not true at all. The graphics card does not need a spinning HDD to send graphics data to the monitor. If that were true, you could never boot into the BIOS or from a flash or optical drive. This is why shutting down the drives and putting the monitor to sleep are separate settings.
plus if computer is not sleeping I have display on the monitor.
Okay, that does suggest the cable is fine. I think the problem is with your card. You need to borrow a different monitor and see what happens before you pull all your hair out. That is the only way at this point to determine if the problem is on the monitor side, or the computer side.

It seems to me you are focusing on HDMI as the culprit. I think HDMI is working fine. I think you need to be focusing on the computer. Do make sure you have the latest drivers for your card.

In Control Panel, click Power Options > Change plan settings. Make sure both display and computer are set to turn off and go to sleep. Then click on Change advanced power settings and expand the Display options. Make sure there Turn off display has a value (other than 0).
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top