Cannot make Chrome default web browser


Joined
Jul 14, 2016
Messages
1
Reaction score
0
I have followed the very clear instructions of settings=>system=>default apps=>web browser and selected chrome.

After repeating the action several times, Microsoft Edge is no longer the default browser, however every time I attempt to select Chrome as the default it will not take. I remain now without a default browser and every time I open Chrome it asks me if I would like to make it my default. If I say yes it opens up settings and this cycle repeats.

I would appreciate any insight. Thanks!
 
Joined
Nov 19, 2013
Messages
4,365
Reaction score
849
Have you worked through the settings, in particular setting your home, and opening pages.

But, for your default, try opening the Control panel - default programs . set your default programs, and select Chrome from there.
 
Ad

Advertisements

Joined
Feb 18, 2016
Messages
2,826
Reaction score
622
Try logging in with an Admin account. I'm not sure about changing default browsers settings, but I do know that certain settings especially in the update and security settings can only be made by an Administrator.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top