SOLVED Can't disable read-only on external HD


Joined
Mar 29, 2017
Messages
11
Reaction score
2
Problem statement: I’m cannot disable the read-only attribute for folders on an external USB hard drive.

OS: Windows 10 Home, Version 1909

H/W: HP 15 Laptop PC (Product Number: 7DF84AV). USB HD is Seagate STGX4000400

This is a new laptop. I have not yet done Windows Updates (actually, I previously did Windows Updates, then encountered this problem, did failed troubleshooting, and then did Windows Recovery [after having read that Windows Updates sometimes introduce challenging read-only problems]). After doing a Windows Recovery, I have removed much of the (e-mail address removed) and I’ve installed Firefox and the LibreOffice suite. I’m holding off on doing Windows Updates this time around so in order to reduce the number of variables).

In all other respects than the read-only problem, the PC seems to be performing normally.

I have a USB Seagate hard drive that I used with my previous Windows 10 PC, an HP Compaq 6200 running Windows Pro. I had used the USB hd as a manual backup device (that is, I didn’t use backup software), with copies of Documents and Pictures folders.

I am logged into the new HP 15 as a user with Administrator privileges.

I have attached the USB hd to the new HP 15 and find that the Documents folder and all folders within Documents are read-only when viewed in right-click in Explorer Properties → General. When the hd was attached to the previous PC these folders were, of course, not read-only. If I try to edit a spreadsheet in the Documents folder, I get “Document is locked for editing by…” I have verified that there is no lock file.

I have attempted to disable the read-only setting (of the Documents folder, for example) via Explorer right-click by unchecking Read-only, then clicking Apply; I choose to apply the change to Documents and all subfolders and files. Windows appears to honor the command, showing a dialog box that says “Applying attributes to” and listing names of subfolders and files. But, if I immediately check the read-only status again, I see that the Documents is still (or again) set to read-only status.

I tried a second method, as follows. I invoke a command prompt, Run As Administrator. I cd to the external hd and do: ‘attrib -R Documents’. The command completes without error, and when I do: ‘attrib Documents’ the only flag shown as being set is ‘I’. Going back to Explorer, I do right-click Properties, and I see that Document is still in read-only mode.

Some solutions for this problem that I have found by googling mention gpedit.msc fixes. But, as I’m sure you know, gpedit.msc is not available in the Home version of Windows.

This seems like a rather basic issue, so probably I’m overlooking something basic.

Thanks in advance for any guidance.
 
Ad

Advertisements

Joined
Apr 22, 2017
Messages
4,032
Reaction score
514
Hi JSG,

did you also try opening the USB drive by right click and open as administrator in File explorer > This PC?. :)
 
Joined
Nov 19, 2013
Messages
5,301
Reaction score
1,080
You can do it through using the Diskpart command. But, is it causing you any problems? It is, and always has been, a built in policy for your protection. If you do remove the attribute, it leaves you more vulnerable to exploitation. Further, as soone as you get a cumulative update from MS, it will revert to read only.
I don't think there is a right click option to open as Administrator?
 
Joined
Apr 22, 2017
Messages
4,032
Reaction score
514
I think you are right Dave, I just plugged in a USB storage thingy and did a right click and there is no option!.

What might also be of interest is right click on the drive then "Properties > Security" and check Allow/Deny settings. :)

1594805707071.png
 
Joined
Nov 19, 2013
Messages
5,301
Reaction score
1,080
Possibly, but my query stands! Why is it presenting a problem? I have a ton of software on an USB external. I can use it, install it, whatever.
He can try you suggestion, but the utility "Take ownership" (which I wrote hundreds of years ago- lol) will do it all automatically. It wont, i think, alter the attributes.
 
Joined
Mar 29, 2017
Messages
11
Reaction score
2
Hi JSG,

did you also try opening the USB drive by right click and open as administrator in File explorer > This PC?. :)
Thank you for the reply.

Let me make sure that I understand your question.

I think you are asking whether: Logged in with Administrator privileges, I went to Explorer's Navigation pane (the pane on the left), expanded 'This PC', then expanded 'Seagate Portable Drive (E)', then right-clicked on 'Documents' in an attempt to uncheck 'read-only'.

If that is your question, then my answer is Yes. I tried that.

P.S. I removed the colon from the E drive specification, above, because I found that colon right parenthesis got converted to a smiley in my post.
 
Ad

Advertisements

Joined
Mar 29, 2017
Messages
11
Reaction score
2
You can do it through using the Diskpart command. But, is it causing you any problems? It is, and always has been, a built in policy for your protection. If you do remove the attribute, it leaves you more vulnerable to exploitation. Further, as soone as you get a cumulative update from MS, it will revert to read only.
I don't think there is a right click option to open as Administrator?
davehc, are you asking whether the read-only setting is causing me problems?

Your post prompted me to do more testing, and I am extremely embarrassed to report that I now have things working, and it was a user error the entire time. I'll explain.

I had been trying to open two commonly edited files using Libreoffice Calc and Writer, and LibreOffice insisted on opening the files in read-only mode. I had noticed that all folders were marked read-only, and I leapt to the conclusion that I had a Windows config problem.

Doing more testing this morning I found that I could create and edit new files in any folder on the USB external drive.

Thinking perhaps this problem is related specifically to Libreoffice files, I then revisited my assumption that there are no lock files.

In Explorer I checked the Hidden Items checkbox and found that there are, in fact, lock files for the problematic files I had been trying to open! I was aware of hidden files previously, but I thought of hidden files as being Windows or application files. I don't recall Libreoffice lock files being hidden in the past.

After deleting the lock files, I can now edit all of the files that I have been trying to edit.

The Documents and subfolders stubbornly continue to show as 'read-only' in Explorer, although that seems to be a false reading.

I am very embarrassed at having wasted the time of you kind folks with my poor troubleshooting.
 
Joined
Apr 22, 2017
Messages
4,032
Reaction score
514
Hi JSG,

glad you got it sorted!. :)

Please mark the thread as solved so it helps others. :)
 
Joined
Mar 29, 2017
Messages
11
Reaction score
2
Hi JSG,

did you also try opening the USB drive by right click and open as administrator in File explorer > This PC?. :)
I did not think of doing that. Thanks for the helpful reply!

Even though I have things working now, I find your suggestion intriguing and it seems like a great operation to add to my toolkit.

When I try to follow your instructions today, I don't see an 'open as administrator' option. Please see the attached image.

I'm sure I misunderstand the details of your suggestion, or I'm overlooking the obvious.
 

Attachments

Joined
Apr 22, 2017
Messages
4,032
Reaction score
514
Hi JSG,

see posts 3 & 4, there is no option, I actually thought there would be but I was wrong as Dave pointed out!. :)
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top