SOLVED Can't type the @ symbol


Joined
Dec 27, 2015
Messages
4
Reaction score
0
Hello everybody!

I have recently bought a brand new computer from Best Buy. Every's been working fine except, I can't type the @ symbol.

I have the standard US keyboard, I also have tried some other keyboards, literally nothing happens when I hold Shift and press 2.

I can type every other symbol no problem, so !#$%^&*()_+ and my number 2 key works.

Note that nothing happens when I press shift + 2, not even a weird " shows up as it does for the french keyboard.

Please help, any feedback is appreciated!

Thanks

Screenshot to system:

Capture.PNG
 
Last edited:
Ad

Advertisements

Bif

Joined
Oct 17, 2015
Messages
1,172
Reaction score
454
Hmmm that is odd...I know with my HP laptop to enable and disable the "blue" keys as they call them I hit control and then both shift keys twice..
But it sounds like this may not help you,but give it a try..
Not knowing your system its a shot in the dark.
 
Joined
Dec 27, 2015
Messages
4
Reaction score
0
Hmmm that is odd...I know with my HP laptop to enable and disable the "blue" keys as they call them I hit control and then both shift keys twice..
But it sounds like this may not help you,but give it a try..
Not knowing your system its a shot in the dark.
this is windows 10 forum right? and idk what blue key you are talking about sorry :/ if its the Fn keys, this has nothing to do with that.
 

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
13,417
Reaction score
2,320
IF you go here Control Panel\All Control Panel Items\Language
What is showing for Display language, Keyboard layout
And if you click options what is shown as input method
 
Joined
Dec 27, 2015
Messages
4
Reaction score
0
IF you go here Control Panel\All Control Panel Items\Language
What is showing for Display language, Keyboard layout
And if you click options what is shown as input method

EN English (United States)

I highly doubt it's an input method problem though :/
 
Joined
Oct 13, 2015
Messages
330
Reaction score
46
Sounds like a defective keyboard. I would take it back to Best Buy or contact them to see if they will exchange just the keyboard.
 
Ad

Advertisements

Joined
Dec 27, 2015
Messages
4
Reaction score
0
Sounds like a defective keyboard. I would take it back to Best Buy or contact them to see if they will exchange just the keyboard.
I thought of that too... same problem for all my 3 keyboards one of which is mechanical :(
 
Joined
Nov 28, 2015
Messages
109
Reaction score
12
Another site suggests that a Comcast security program called "Constant Guard" may be the culprit. (Do you use Comcast?) Uninstalling that program reportedly solved similar keyboard related issues. I can't personally verify this so treat the following suggestion with all due skepticism.

Go to: Control Panel > Programs > Programs and Features

If you find Constant Guard on the list, uninstall it and reboot.
 
Joined
Jun 25, 2015
Messages
88
Reaction score
7
press and hold Alt (left)
on numerical keyboard type "0064" without quotes
release Alt key
 
Joined
Jan 22, 2018
Messages
1
Reaction score
0
for some odd reason, windows button + spacebar will switch to different language preferences in windows 10(latest update hav it) . I have trouble typing '@' for 3 days and it come out "#" instead too. I use US Keyboard setting, - solved. :)
 
Joined
May 6, 2015
Messages
2,842
Reaction score
500
Trying to set up an input field for email addresses on old 3278 terminals...and found they had no '@' key.
 
Ad

Advertisements

Joined
Oct 13, 2015
Messages
330
Reaction score
46
Would have been nice if the OP had gotten back with us to tell us what solved the problem if it was solved. Maybe pressing a key just vaporized him/her. I would have taken the new computer back to Best Buy.
 
Joined
Jan 22, 2018
Messages
81
Reaction score
14
Hi Guys and Gals. It's quite normal for OP,s not to respond after posting and asking for help. I agree it can be flustering, but it happens a lot. You just keep trying to help members, and hope you help someone with a issue and they respond back.
 
Joined
Mar 18, 2021
Messages
1
Reaction score
0
Hello everybody!

I have recently bought a brand new computer from Best Buy. Every's been working fine except, I can't type the @ symbol.

I have the standard US keyboard, I also have tried some other keyboards, literally nothing happens when I hold Shift and press 2.

I can type every other symbol no problem, so !#$%^&*()_+ and my number 2 key works.

Note that nothing happens when I press shift + 2, not even a weird " shows up as it does for the french keyboard.

Please help, any feedback is appreciated!

Thanks

Screenshot to system:

View attachment 1965
If you hold shift and type the inverted comma button ("), you'll find it's the @ symbol. For some reason they're swapped! Happened to me too.
 
Joined
Mar 22, 2021
Messages
14
Reaction score
2
The @ symbol on an American keyboard is on the number 2 key and on a UK one it’s on the apostrophe key, second right of the L key, if your PC is set to UK language, you use the keys the opposite way around to what yours are marked, ie, hold down shift and then 2 for the apostrophe and hold down shift and press the apostrophe key for @
 
Ad

Advertisements

Joined
Nov 2, 2022
Messages
2
Reaction score
0
Losing my mind. I'm having this exact issue, everywhere else assumes its a keyboard language problem and I finally find someone who has the issue like I have it and it goes completely unresolved.

It is not a keyboard language issue. Shift+2 doesn't create a " or a * or a # or any symbol at all. It simply does nothing. Pressing " doesn't create the @, nothing is swapped, the only way to get @ is using the alt code. Shift+2 does nothing, but the rest of the symbols on the number row work fine. !#%$%^&*()_+. The number 2, without shift, works fine. 2222222222.

Language is set to US English.

I don't use Comcast and don't have "Constant Guard" installed.

I am noticing something peculiar though, using https://keyboard-test.space/, it can't register both buttons pressed at the same time. If I'm holding shift, and press 2, it doesn't register my 2 presses until I let go of Shift. If I hold 2, and press shift, it won't register my shift presses until I let go of 2. This does not happen when I'm holding shift and pressing any other key, nor when I'm holding 2 and pressing any other key— it registers all those just fine. It's only the combination of Shift and 2 that doesn't register. This is also regardless of if I'm using Left Shift or Right Shift.

It's... bizarre, and annoying.
 
Joined
Nov 28, 2015
Messages
109
Reaction score
12
IDK, possibly a keyboard hardware issue. Have you tried using a different keyboard? Or if using a laptop, try a USB keyboard.
 
Ad

Advertisements

Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top