Corrupt system files, DISM not working for some reason


Joined
May 27, 2021
Messages
1
Reaction score
0
Okay, so basically, about a week ago, some of my PC's system files got corrupted. This caused File Explorer, Taskbar, PC Settings, and some other Windows features to stop working. Upon logging in to my PC, The process for File Explorer would go into a loop of opening and then crashing. Everything else on my PC seems to work fine, as long as it doesn't try to use windows' native file open dialogs. I've been trying to fix this, but so far, nothing I've done up to this point seems to work:
  • Booting into Safe-Mode doesn't seem to solve it, so I'm mostly sure none of my programs are causing it.
  • chkdsk says the drive is fine, so its not a failing hard-drive.
  • sfc /scannow says it was able to repair some files, but not the one resulting in File Explorer not working correctly. (I've read that this is because the backup system files sfc would use are also probably corrupt).
  • I would use a System Restore point, but I forgot that I had to manually enable them when I got my PC a couple weeks ago.
Finally, I've been trying different variations of DISM, which is confusing me as to why this one isn't working; I understand why the others aren't, but this one stumps me, and searching the Internet for answers hasn't given me any conclusive answers (unless I'm looking in the wrong places).

DISM /Online /Cleanup-Image /CheckHealth
and
DISM /Online /Cleanup-Image /ScanHealth
tell me that the component store is repairable.

So when I go to use
DISM /Online /Cleanup-Image /RestoreHealth
it works quickly up until hitting 62.3%, at which it will go no further. From reading up online, I've come to understand that it is normal
for it to get stuck at a percentage for awhile and then complete with no issues.
However, after leaving it on overnight for approx. 5-6 hours, it hadn't moved from this point at all.

I didn't want to leave it running for much longer, so I closed it and restarted my PC.
My PC would then say "Getting Windows Ready" and would take 2 hours before it finished when I restarted my PC.
It did this almost everytime I ran DISM /RestoreHealth.

I've also tried using a bootable USB as a /Source for it, and I've made sure my internet never went down while it was running,
and neither of these factors seem to have affected it at all.
I've looked at the log files it produces, but I can't quite make sense of it (I've attached the log from my final attempt at using DISM if you guys might know what it's saying).

The only other thing I remember trying is running /StartComponentCleanup beforehand on one of my attempts (without the /ResetBase parameter).

I'm at a roadblock for ideas of what I could be doing wrong with this program, or if there's potential damage that prevents it from working. I'm considering doing an in-place upgrade but I am a little nervous about having to redo all my settings (unless there's a way to back them up), not to mention having to potentially restore all of my files from backup if data loss occurs. I'm also just kind of curious about what's happening because I'm kind of a computer-enthusiast.
 

Attachments

  • finalattempt.log.txt
    35.9 KB · Views: 83
Ad

Advertisements

Joined
Apr 18, 2021
Messages
63
Reaction score
14
If you do a search on 'warning' in that text file there are two messages warning of a 'failure to load provider'....
2021-05-25 16:40:51, Warning DISM DISM Provider Store: PID=14672 TID=23584 Failed to load the provider: C:\Users\winke\AppData\Local\Temp\01DC338F-2D24-4277-BF8D-C3E414EACEF8\PEProvider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x8007007e)

...and at the end there is another warning that an 'AddSource failed'...
2021-05-25 16:40:51, Warning DISM DISM Package Manager: PID=14672 TID=23584 CBS AddSource failed with HRESULT=0x8007007b! - CDISMPackageManager::Internal_Finalize

That 0x8007007b error code is an activation error indicating that the source you used may not be for the exact same version that you have installed or that there is a Windows activation issue with your system.

An in-place upgrade will be a disaster if your component store is damaged and a Windows Reset may not be able to recover either, though it's worth a try. I would select the cloud install method and download a new image. If all that fails I think you'll have to bite the bullet and do a fully clean reinstall from bootable media.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top