SOLVED EPSON R300 DRIVER


Joined
Feb 13, 2016
Messages
1
Reaction score
0
I was able to fix the Windows 10 update for my R300, But it will not write on a DVD.
 
Ad

Advertisements

Joined
May 24, 2016
Messages
1
Reaction score
0
Hello Tom 06.Many thanks for your tip it worked for me, and as Borislav points out ink levels are a minor problem!!
Cheers
 
Joined
Sep 23, 2016
Messages
1
Reaction score
0
Hi Sandoug,

I had the same problem and have found a solution from another forum:

Windows10 Control Panel
-> Open 'Devices and Printers'
-> Click 'Add a Printer', which is a button found at the top of the window
-> Click 'The printer that I want isn't listed', at the bottom of the window
-> Select 'Add a local printer or network printer with manual settings'
-> Select 'Use an existing port: USB0001 (Virtual printer port for USB)'
-> Select 'EPSON' in the left window and 'Epson Stylus Photo R300 (M)' in the right window
-> Select 'Use the driver that is currently installed (recommended)'
-> Chose a name for the printer

It should then appear on your printers and devices and work properly..!

Thanks Tom06 - worked like a charm! Just wondering if you have got the CD/DVD printing to work as well? I'm working on it, but if you have any suggestions..
 
Joined
Sep 6, 2017
Messages
1
Reaction score
0
Greetings. "Forced" to transfer to Win 10 a couple of months ago. Have tried the method described above, and it appears to install OK, but as soon as I try to print with the R300 I get a message that theprinter is "offline". The window to allow selection of type of print and paper type etc is displayed if requested.
System - Windows 10 Home; 64 bit OS; Version 1607; OS Build 14393.1593
Any help woould be much appreciated.
 
Joined
Sep 12, 2017
Messages
1
Reaction score
0
Hi Sandoug,

I had the same problem and have found a solution from another forum:

Windows10 Control Panel
-> Open 'Devices and Printers'
-> Click 'Add a Printer', which is a button found at the top of the window
-> Click 'The printer that I want isn't listed', at the bottom of the window
-> Select 'Add a local printer or network printer with manual settings'
-> Select 'Use an existing port: USB0001 (Virtual printer port for USB)'
-> Select 'EPSON' in the left window and 'Epson Stylus Photo R300 (M)' in the right window
-> Select 'Use the driver that is currently installed (recommended)'
-> Chose a name for the printer

It should then appear on your printers and devices and work properly..!
OMG - this worked!!!! I have spent hours on the phone with both Epson and Microsoft support and they had no clue :( Thanks so very much!!
 
Joined
Feb 22, 2018
Messages
2
Reaction score
0
I tried 'Tom06's method but the r300 (M) wasn't in the right window so I used 'Trouble's method first.
This is what worked for me. I also got the ink levels working.

Use Internet Explorer and go here
http://catalog.update.microsoft.com/v7/site/Search.aspx?q=Epson Stylus Photo R300
The slightly larger of the two drivers available (4.7 MB) is for 64 bit versions of Windows, while the smaller (4.6 MB) is for 32 bit versions of Windows. Be sure to choose the correct version for your system architecture.
Download it put it in a new folder on your desktop.
That will provide a folder containing
AMD64-all-5098_a1b99bb764e2c49ac8170f9e96164a608254a9e5.cab
NOW
You need to install something like 7zip from here http://www.7-zip.org/
After you have that installed it will add a 7zip feature to your right click context menu.
Right click the cabinet file and select 7zip -> extract here
That will provide you the prnep00d.inf file that you will need to browse to.


Windows10 Control Panel
-> Open 'Devices and Printers'
-> Click 'Add a Printer', which is a button found at the top of the window
-> Click 'The printer that I want isn't listed', at the bottom of the window
-> Select 'Add a local printer or network printer with manual settings'
-> Select 'Use an existing port: USB0001 (Virtual printer port for USB)'
-> Click 'Have Disk'
-> Click 'Browse' and select the folder you downloaded and extracted the above 'cab file' to
which should contain the prnep00d.inf file.
-> Select 'next'
-> Select 'EPSON' in the left window and 'Epson Stylus Photo R300 (M)' in the right window

Once installed you can get the familar 'Printing Prefrences' box up by:

-> Open 'Control Panel'
-> Select 'Devices and Printers'
-> Right click 'Epson Stylus Photo R300 (M)'
-> and choose 'Printing Prefrences'
-> click 'Ink Levels'

You know the rest. Dont know how to get it to show up in the task bar how it used to but hey it's working.
 
Ad

Advertisements

Joined
Feb 22, 2018
Messages
2
Reaction score
0
Update.... here's how to put a shortcut to 'Printer Prefrences' on your desktop:

-> open 'Control Panel'
-> Under 'Hardware and Sound' click on 'View devices and printers'
-> Right click on 'Epson Stylus Photo R300 (M)' and select 'Open'
-> Right click on 'Adjust print options' and select 'create shortcut'
-> select 'Yes' to 'Windows can't create a shortcut here. Do you want
the shortcut to be placed on the desktop instead?

Just double click this shortcut to set your print prefrences and monitor ink
before your print job.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top