SOLVED Error Event (ID 11) logged following 'Eject' of CF card.


Joined
Apr 16, 2016
Messages
27
Reaction score
3
System details:-

Akasa USB 3.0 SuperSpeed Memory Card Reader AK-ICR-14

Edition Windows 10 Pro
Version 21H1
Installed on ‎29/‎05/‎2021
OS build 19043.1165
Experience Windows Feature Experience Pack 120.2212.3530.0

Problem:-

Each time I eject a CF card from the taskbar, I get three consecutive error messages reported in the Event Log:-
ID: 11 The driver detected a controller error on \Device\Harddisk2\DRx.
Each of the three events is separated in time by about 1 second.
The drive name DRx increments each time a CF card is plugged in & ejected.
The errors are reported even without physically unplugging the CF card.
The errors happen even if the card is not in use (i.e. not being read).

This happens with every CF card I have tried. Files on the cards can be read without problems.

I am unsure if this problem only began to appear following a Windows 10 update.

The problem does not happen when using a USB stick inserted in the USB 3.0 socket on the Akasa card reader.
It only happens when using a CF card (formatted in a Nikon D810).

According to Device Manager, I have Realtek USB 3.0 Card Reader driver version 10.0.17763.31247.
Attempts to update the driver give a message telling me that Windows thinks it is up to date.
However, searching the web, I have found a later version: 10.0.19042.31267 dated 2021 from softpedia.com.
I could not find this driver on the Realtek website. They just have 10.0.370.188 dated 2018.
I tried updating the driver but it made no difference to the errors.

====

Log Name: System
Source: disk
Date: 26/08/2021 09:04:07
Event ID: 11
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: DESKTOP-383S470
Description:
The driver detected a controller error on \Device\Harddisk2\DR10.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="disk" />
<EventID Qualifiers="49156">11</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2021-08-26T08:04:07.7058395Z" />
<EventRecordID>13647</EventRecordID>
<Correlation />
<Execution ProcessID="4" ThreadID="18172" />
<Channel>System</Channel>
<Computer>DESKTOP-383S470</Computer>
<Security />
</System>
<EventData>
<Data>\Device\Harddisk2\DR10</Data>
<Binary>0E00800001000000000000000B0004C003010000000000000000000000082D00000000000000000068F09C0200000000FFFFFFFF06000000580000000000000000000612080000100000000041000000000000000000000080AFEF0907CFFFFF000000000000000010700E0407CFFFFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</Binary>
</EventData>
</Event>

====
 
Ad

Advertisements

Joined
Apr 16, 2016
Messages
27
Reaction score
3
Oops. Typo in the thread title. I don't know how to edit it. The Event ID should be 11 not 12.
The title should read:-

Error Event (ID 11) logged following 'Eject' of CF card.​

 
Joined
Apr 16, 2016
Messages
27
Reaction score
3
I think I may have found the problem...

I downloaded and installed the original driver for the Akasa AK-ICR-14 card reader from here:-
Akasa Thermal Solution

Now when I check the Realtek USB3.0 Card Reader Driver Version in Device Manager, I get:-
Driver Date: 18/10/2017
Driver Version: 10.0.16299.31239

The Event ID 11 errors on ejecting the CF card have gone away.
What's more, I now get a notification message telling me that it is safe to unplug the card.
That message stopped working when I started getting the errors.

When I first noticed the problem, the Realtek driver version was 10.0.17763.31247
It looks like a Windows Update had replaced the driver with a later version that doesn't work correctly with the Akasa card reader.

A later version of the Realtek driver (10.0.19042.31267) from softpedia.com gives the same problem.

The solution is to stick to the original driver.
No doubt a future Windows Update will update the driver and screw things up again.
 
Ad

Advertisements

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
13,224
Reaction score
2,271
Thanks for the follow-up and providing your solution.
Much appreciated.
Best
Randy
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top