SOLVED Group Policy Client Service Problem & no regedit


Joined
Jun 20, 2016
Messages
10
Reaction score
0
I have a similar problem to Janelda in a previous thread in which contributor regedit32 provide detailed steps.
https://www.windows10forums.com/threads/windows-couldnt-connect-to-group-policy-client-service.8707/

I have confirmed my details as correct to the stage where regedit is invoked. However I have not been able to open regedit either at the command prompt or via either SysWow64 entries so would appreciate additional instructions. In all cases they time out with "Service does not respond to start or control request in a timely fashion".

Background
elevated command prompt not available but command prompt is.
Task manager and Window update won't open. All time out with "Service does not respond to start or control request in a timely fashion".
Restore is not accessible
IE and other installed programs open but Acronis does not.
Very slow to shut down

System Information
Originally Win 7 then free upgraded to Win10
Last windows update was KB3149135 16Jun16 (Did the problem start here?)

OS Name Microsoft Windows 10 Home
Version 10.0.10586 Build 10586
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name Nigel-PC
System Manufacturer Dell Inc.
System Model Vostro 200
System Type x64-based PC
System SKU
Processor Intel(R) Pentium(R) Dual CPU E2160 @ 1.80GHz, 1800 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date Dell Inc. 1.0.3, 12-Jul-07
SMBIOS Version 2.5
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer Dell Inc.
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = "10.0.10586.0"
User Name Nigel-PC\Nigel
Time Zone New Zealand Standard Time
Installed Physical Memory (RAM) 4.00 GB
Total Physical Memory 3.24 GB
Available Physical Memory 1.42 GB
Total Virtual Memory 6.49 GB
Available Virtual Memory 4.40 GB
Page File Space 3.25 GB
Page File C:\pagefile.sys

Thank you for your interest and any support you are able to provide.
Warm regards
Nigel
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,124
Hi Nigel,

As you are using a Home edition of Windows 10 the option to take control of Registry via the Group Policy Editor is not applicable, albeit you can in theory install this on a Home edition of Windows 10 and run it.

Have you have any virus infections recently? I ask, as its possible this has overwritten policies that affect the use of applications like Regedit.exe and Regedit32.exe and may have also affected elevation commands such as cmd.exe being run as an Admin.


One way you can check whether policies are the cause of this inability to open your Registry editor is to query two keys within the registry via a standard non-elevated command prompt.

  • Right-click on Start then select Command Prompt
  • At the Command Prompt you can type or copy & paste the following two commands, pressing Enter key after each command to execute. Post back the results:

    Code:
    reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System"
    Code:
    reg query "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System"
    Example image

    reg query policies.png

  • In the event you come across a value named DisableRegistryTools with a Data value of 1 you will have come across the cause of your troubles. To remedy this you can overwrite the value via your Command Prompt by typing or copy & pasting the following two commands, pressing Enter key after each command, and if prompted typing Yes to allow the overwrite to take place.

    Code:
    reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System" /v DisableRegistryTools /t REG_DWORD /d 0
    Code:
    reg add "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System" /v DisableRegistryTools /t REG_DWORD /d 0
    Note: These are the two entries created when one uses their Group Policy Editor to disable the Registry access. 0 = access available, 1 = no access available.

    After making these additions to your Registry press F5, then close all open applications and shut down computer. Restart computer and test whether your system allows you access now to the Registry.

Sorry I've missed your inbox and previous posts on an older solved thread. I've been a little distracted with rehabilitation after surgery. It is better though to begin a new thread as you have now done rather than attempt to open one within a solved thread, as generally the only reason one reads a solved thread is to find a solution to their own problem.

Regards,

Regedit32
 
Joined
Jun 20, 2016
Messages
10
Reaction score
0
Hi Nigel,

As you are using a Home edition of Windows 10 the option to take control of Registry via the Group Policy Editor is not applicable, albeit you can in theory install this on a Home edition of Windows 10 and run it.

Have you have any virus infections recently? I ask, as its possible this has overwritten policies that affect the use of applications like Regedit.exe and Regedit32.exe and may have also affected elevation commands such as cmd.exe being run as an Admin.


One way you can check whether policies are the cause of this inability to open your Registry editor is to query two keys within the registry via a standard non-elevated command prompt.

  • Right-click on Start then select Command Prompt
  • At the Command Prompt you can type or copy & paste the following two commands, pressing Enter key after each command to execute. Post back the results:

    Code:
    reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System"
    Code:
    reg query "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System"
    Example image

    View attachment 3311

  • In the event you come across a value named DisableRegistryTools with a Data value of 1 you will have come across the cause of your troubles. To remedy this you can overwrite the value via your Command Prompt by typing or copy & pasting the following two commands, pressing Enter key after each command, and if prompted typing Yes to allow the overwrite to take place.

    Code:
    reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System" /v DisableRegistryTools /t REG_DWORD /d 0
    Code:
    reg add "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System" /v DisableRegistryTools /t REG_DWORD /d 0
    Note: These are the two entries created when one uses their Group Policy Editor to disable the Registry access. 0 = access available, 1 = no access available.

    After making these additions to your Registry press F5, then close all open applications and shut down computer. Restart computer and test whether your system allows you access now to the Registry.

Sorry I've missed your inbox and previous posts on an older solved thread. I've been a little distracted with rehabilitation after surgery. It is better though to begin a new thread as you have now done rather than attempt to open one within a solved thread, as generally the only reason one reads a solved thread is to find a solution to their own problem.

Regards,

Regedit32
Hi Regedit32,

Many thanks for responding to my situation. I trust the rehabilitation is well on the way and everything is functioning comfortably.

The computer with the problem is not run very regularly as it is mainly used for amateur radio call logging rather than surfing the net and I have not been on the air for while recently. It has a version of MacAfee on it and I cannot recollect any malware issues.

Here is a screen print of the two registry queries:-

nigelnz22 CmdQery1.gif

(I chose to insert a Full Image not Thumbnail - hopefully that's the right size.)

The first query produced an output, the second one failed.

Thank you again for your help and interest.

Regards

Nigel
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,124
Thanks Nigel,

Your results show a couple of items of interest.

I see you've previously edited the registry yourself, or possibly applied a hotfix Microsoft supplied for Windows Vista/7 users that created that last entry in your results for:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Polices\System

There you have the Data entry: EnableLinkedConnections. Microsoft recommended adding this key a while back when they became aware some Vista and 7 users after enabling UAC had troubled connecting to a network.

This key is not normally present in a standard Windows 10 build, so I have to assume you've added this yourself.

You should not need this entry at all and could consider removing it.


The other thing I noticed is you are actually missing a entry: FilterAdministratorToken. This 32-bit DWord value is normally present and set to a default data value of 0, which disables this function. It should be present and in some cases the user actually needs to set the data value to 1 to enable the function. For example, if you have enabled the hidden built-in Administrator in Windows 10 if you have not enabled this function you will be unable to open several of the universal apps as these apps expect a UAC call. Enabling the FilterAdministratorToken allows such apps to see the current user's choice as an Admin approved action which then allows certain applications to open and run as expected.

You could add this via a command prompt:
  • Right-click on Start and select Command Prompt
  • At the prompt type or copy & paste the following command, then press Enter key to execute:

    Code:
    reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /v FilterAdministratorToken /t REG_DWORD /d 0x00000000
    Note: You will need to shut down computer, then restart it for this change to take affect.

Once added and you have restarted computer see if things improve, if not using the same command above you could overwrite the entry by replacing the data value with 0x00000001 to enable the token.

Regards,

Regedit32
 
Joined
Jun 20, 2016
Messages
10
Reaction score
0
Hi Regedit32,

Thank you again for your help. I have never edited the Registry apart from increasing the poling time for windows to synchronize computer time with a time standard. The windows 7 was a clean install with a genuine MS CD so guess it must have been the patch.

Ok on the removal of EnableLinkedConnections. I would need some instructions to do this.

I executed the FilterAdministratorToken and got this:-
nigelnz22Cmd Qry2.PNG


Tried it twice in case I miscopied the line.

Then decided to restart the computer and try again. Upon doing so the shutdown and start up included a windows update sequence and eventually upon restarting - Big Surprise - everything seems back to normal!

Task Manager, elevated command prompt, regedit and restore etc are now all accessible and Acronis starts.

The update was KB3163018.

I re-ran the three previous registry queries and here are the returns:-

nigelnz22Cmd Qry3.PNG


Will await your comments before doing anything else.

Regards from a surprised
Nigel
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,124
Nothing like an update to cure a few glitches :)

If you want to remove that EnableLinkedConnections you can either go to its location in the Registry Editor, then right-click and delete it, or via a command prompt:
  • Code:
    reg delete "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /v EnableLinkedConnections

Keep an eye on that Registry subkey and make sure your FilterAdministratorToken does not go on another walk-about and disappear from this location. It needs to be there for most of the universal apps and a few other applications to function.

If your issue is now resolved don't forget to mark the thread as solved too.

Note: The Data Value for FilterAdministratorToken by default is 0 (disabled), but should you decide you wish to run your machine using Built-in Administrator you will need to modify that entry to be a 1 (enabled) in order to be able to use the Universal apps, MS-Edge, etcetera.

Regards,

Regedit32
 
Last edited:
Ad

Advertisements

Joined
Jun 20, 2016
Messages
10
Reaction score
0
Many thanks, Regedit32, for your helpful suggestions and the time you have devoted to my problem. Very much appreciated.

Warm regards

Nigel
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top