Internet keeps disconnecting


Joined
Aug 17, 2015
Messages
108
Reaction score
2
I tried Windows 10 a few weeks ago and went back to 8.1 for various reasons the worst being that it keeps dropping the internet connection. Windows claims the currents drivers for my Broadcom NetLink (TM) Gigabit Ethernet adapter are up to date.

When this happens (unlike in previous windows versions) troubleshooting does not correct this, at least not the first time, it tries for at least 5 minutes and fails I then try to restart but it hangs on restart so I have to close down then restart then troubleshoot again then it finally connects. This is identical behaviour to 2 weeks ago when I tried Windows 10.

Don't particulary want to go back to 8.1 but seems as though it could be the only way.
 
Ad

Advertisements

Joined
Aug 17, 2015
Messages
108
Reaction score
2
If you have the same Broadcom adapter I managed to locate the drivers k57nd60a .cat .inf and .sys and it SEEMS to be OK now
 
Ad

Advertisements

Joined
Dec 24, 2016
Messages
1
Reaction score
0
hello everyone , you can follow the link to check the video , and it will help to solve the issue


1 download the correct driver
2 install the driver manually but from the disk(let me check the driver list in my pc > From disk )
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top