MAIL not syncing with Exchange Server to receive messages or load calendar


Joined
Apr 27, 2017
Messages
10
Reaction score
0
Since approx 2 weeks I have not been able to sync my messages from my office MS Exchange Server into the Mail app

I can send emails from the app

All I get is a message "Nothing has arrived yet"

Other forum advice says to give permission to Mail & Calendar in the Privacy settings but when I open my Privacy settings and move to "Contacts" Neither "Mail" nor "mail connector" appear in the list. As I don't know how to add these to the list I am unable to make any sense of this instruction.

Would dearly love to hear from someone who knows how to fix this problem
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,202
Reaction score
999
Hi Quaggie,

Welcome to the Forum.

When you say, 'Mail app', are you meaning the Universal Mail app that comes with Windows 10?

The 'other forum' may have been referring to Outlook where upon opening it, you'd select the Calendar tab and adjust settings there to allow other apps permission to access the Exchange Server.

If you can clarify precisely which Mail app you mean I'm sure someone will be able to assist you.


Regards,

Regedit32
 
Joined
Apr 27, 2017
Messages
10
Reaction score
0
Yes I am referring to the Mail App that came with Win 10. It worked when I first got my laptop but not any more as far as MS Exchange server emails are concerned. I can see the entire email folder list as I have in Outlook but no emails
 
Joined
Apr 27, 2017
Messages
10
Reaction score
0
I have tried all the fixes recommended in that link - Once again it talks about Mail & Calendar whereas the app I am using is the Mail app that comes bundled with Win10.

As I said at the start everything was working fine until a few weeks ago but now I can only access my GMail account but no such luck with the MS Exchange account.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,202
Reaction score
999
That is correct - it is dealing with the Universal app Calendar and the other universal app Mail ( the one you say you are using ).

You must sync these two and ensure your Regional settings like date, time, location are accurate for Mail to work as expected.
 
Joined
Apr 27, 2017
Messages
10
Reaction score
0
All settings are correct and have been working fine for 18 months so why the sudden failure?

mail is working fine for Gmail

Mail also shows the ENTIRE folder setup for my Exchange emails but there is not a single email being downloaded from the server

Mail is also sending emails from this Exchange account but does not record it in the app.

I have attached various screenshots to show
a) Mail & Calendar app says it is installed
b) Apps Installed list shows this app installed
c) Default apps for mail fails to show the M&C app

Browsing for the app takes you to the app store and choosing simply takes you to the app which says that it is already installed.

Something is basically WRONG with my system in the MAIL system and it is something that has occurred in the last few weeks.

Has there been a MS update for Win10 that could have done this?
Mail and Calendar screenshot.png
Apps List installed on PC.png
Default Mail Apps.png
Mail and Calendar screenshot.png Apps List installed on PC.png Default Mail Apps.png
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,202
Reaction score
999
It sure appears to be correct.

It's difficult to say for any certainty why suddenly it will not work as expected.

I don't suppose you have any restore points dated pre this issue arising do you? If you did it would be worth restoring to that point to confirm its working fine there, then update Windows again, to see whether an actual update is what is triggering this. If it's an update you could use the Feedback app to let Microsoft know about it.
 
Joined
Apr 27, 2017
Messages
10
Reaction score
0
Most annoying

I will check the updates to see if I can find a restore point and come back to report
 
Joined
Apr 27, 2017
Messages
10
Reaction score
0
The only system restore point I can find is when I upgraded to WIn10Pro on 26 April.

Mail was already misbehaving before that and this came up as a possible solution so I paid for the upgrade but it seems like I wasted my money. Thank you MS - for nothing.

Yes I am really peed off

What is the solution?
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,202
Reaction score
999
Oh so the issue actually began when running Windows 7, not Windows 10?!

If that is the case a clean install, not an upgrade ought to sought things.

The Windows 10 license is for the machine, so you won't lose that, but you will need to re-install the same Build and version of Windows 10 you chose.
 
Joined
Apr 27, 2017
Messages
10
Reaction score
0
Incorrect - this Notebook has ALWAYS had Win10 that came pre-loaded but it appears that it was a "Home" version and I was told to upgrade to PRO to overcome this problem
 
Joined
Apr 27, 2017
Messages
10
Reaction score
0
Happy to be corrected but from what I know about Win7 it does not really support MAIL
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,202
Reaction score
999
Ahh yes LoL -- my mistake. Sorry I'm dealing with a few threads and lost context of your issue.

Whomever told you using Pro versus Home would fix this was mistaken, as it appears for some Users this is an ongoing bug.

I myself using a Home version had a few teething issues with Mail app, not syncing, and also continually moaning about settings being out of date.

At first I thought it was an issue with my ISP as they were in the process of dumping the Yahoo servers they store email on because of the serious Hacks and account information theft, so I persevered with the app, resetting Account information and would get temporary use, only to see it flop after a reboot of computer.

In the end I installed another email application, set it up and downloaded all the emails on my ISP's server,

Then I used the PowerShell app (running it as Administrator) and removed the Mail and Calendar app.

I then created a Temporary User account, which I switched my normal User Account's Microsoft account with.

Logged into Store with the Temporary User Account signed in and downloaded the Mail and Calendar app, installed it, then signed out.

I swapped the Microsoft Account back to my usual User account, and restarted computer.

On restarting it, I removed the Temporary User Account and opened the Mail app and set up my email account again, and this time it worked fine, and has continued to work fine since.


It would be worth a shot if you feel up to it.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,202
Reaction score
999
After running PowerShell as Administrator type or copy & paste the following to remove the Mail and Calendar app:

Code:
Get-AppxPackage *windowscommunicationsapps* | Remove-AppxPackage
Press Enter key to execute
 
Joined
Apr 27, 2017
Messages
10
Reaction score
0
Thank you for giving me hope that there is a way out of this mess. I was so losing hope and your have changed all that.

Whew !!! that sounds like a week's work !!!!! But I feel that I am up to the challenge.

Just give me a few days to find some valuable time to start the process and I will come back for more advice on particular aspects of each step should I need more direction/clarification.
 
Joined
May 6, 2015
Messages
2,446
Reaction score
380
You are connecting to a real Exchange server right? Is Exchange running on a domain on a MS server? Is that why you upgraded to W10 pro to log on to a Domain? Granted it was some time ago before retirement but my company always used real Outlook as part of Office to talk to Exchange. From Post #2 you are using Mail and also using Outlook? I am missing something here. Why not just use Outlook as with Exchange as Mr Gates intended.
 
Ad

Advertisements

Joined
Apr 27, 2017
Messages
10
Reaction score
0
Yes my emails are on a domain and I am running MS Exchange in my office server (MS SBS 2003)

From day 1 of getting this new Notebook in early 2016 I set up my emails with Mail (this was the Win10 default) and everything worked reasonably well. I no longer had to VPN to my office to look at my mail using Outlook as I did with my previous notebook.

All this changed about two or three weeks ago when suddenly I noticed that the emails were not updating on the office emails but fine with my gmail account.

The rest is in the threads above/below !!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top