SOLVED Mapped Drives with Apache Server

Jun 19, 2023
Reaction score

I have six Windows computers connected to a Synology NAS. The Windows machines run Apache Web Server v.2.46 and have all the web data (logs and root directories) on the NAS drive which is mapped as Z: On three of the computer this works fine and I run one web server at a time. The other three are theoretically identical but won't start the Apache service.

The three computers that work all have a red X associated with drive z: The three that don't work do not have the red X. All six machines map the drive with a startup batch file with the command net use net use z: \\server\root /user:Username password /persistent:yes This also works.

On the three computers that don't work the Apache service fails to start with a 7024 error. The only difference between all six computers is the machine name. Some are Windows 10, others are Windows 11 and all are up to date, but there is no correlation between operating systems and functionality.

On all six machines a Command Prompt window sees the data on drive z: both in standard user and administrator modes.

All the services log in with the Local System Account.

The NAS has several external portable drives which are mirrors of the data. I can take a portable drive and plug it in to one of the servers that doesn't work, change the drive letter in the Apache config and the service starts fine. That tells me this is a drive mapping or permission problem, but I have not been able to track it down on the machines that don't work.

Any ideas of where to look?

Thank you.
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question