Sudden DNS timeouts with “Server: UnKnown” on Windows 10 Home system

Jun 13, 2019
Reaction score

A Windows 10 Home Edition is working just fine when suddenly apps requiring public internet connections start to fail or freeze. Analysis shows that DNS has failed. I’ve tried everything I can find from many hours of searching that looks halfway appropriate to no avail. Want to avoid reloading the system as I have better things to do on my weekends.

Problem Description

DNS operations fail on Windows 10 Home edition system. The house is full of other computers, both Windows Home and Windows Professional, that keep on working when the one problematic computer stops.

The failing computer can previously be working for hours, even days, when suddenly DNS stops. I have not yet correlated any particular activity to the failure. Today there were both Windows 10 updates and a few application updates pending that needed a reboot.

This is a home system on a FIOS router without a real DNS service so all “reverse DNS” solutions are inappropriate and will be down voted unless someone gives me reason to hope their solution will applies to Windows Home systems in a home when all other computers are fine.

My windows “hosts” files has the IP addresses and names for a few special systems. A ping on them resolves the correct IP address so such pings work but nslookup commands still fail.

Problem Diagnostic

The following always happens when the problem is active:

DNS request timed out.
timeout was 2 seconds.
Server: UnKnown

(note the upper case K)

When the system is up the Server is populated by the name of the router. In all cases the IP address of the router is provided.

Accessing external systems by IP address works just fine so the hardware itself is up.

Reboots that work

A “safe boot” restart clears the problem. This needs to be followed by a regular boot.

A shift-restart slow-boot to completely restart the system also works.

Looking for something gentler, and even better, a fix to prevent this error.

What Doesn’t Work

All Network Settings troubleshooter and repair options do not help.
Series of standard ipconfig commands when run as administrator:

ipconfig /flushdns
ipconfig /registerdns
ipconfig /release
ipconfig /renew

The following are also useless to me for avoiding reboot as they require it

NETSH winsock reset catalog
NETSH int ipv4 reset reset.log

NETSH int ipv6 reset reset.log

Manually change DNS to (Google public DNS) does not help.

DNS request timed out.
timeout was 2 seconds.
Server: UnKnown

Have scanned for viruses. Malware Bytes comes up with what looks like a PUP false positive to a Firefox configuration file. Avast Free and Windows Defender find nothing.

-Software Information-
Components Version: 1.0.586
Update Package Version: 1.0.10708
License: Trial

-System Information-
OS: Windows 10 (Build 17134.765)
CPU: x64
File System: NTFS
User: System

File: 1

The prefs.js file is full of nothing but calls to the user_pref() function.
user_pref("accessibility.typeaheadfind.flashBar", 0);
user_pref("app.normandy.first_run", false);
user_pref("app.normandy.startupRolloutPrefs.extensions.fxmonitor.enabled", true);
. . . . .


Oct 27, 2013
Reaction score
Interesting problem! How often does this problem happen?

Which anti-virus software are you using? Do you know if it uses a pass-through virtual network adaptor as part of it?

I had a similar problem to this a couple of years ago and it turned out to be a problem with my network adaptor (never figured out if it was a driver or hardware problem). Whenever I had transferred a particularly large amount of data (i.e. network backups), I got a similar problem where DNS would fail. I never got to the bottom of it, I just switched out the network adaptor.
Oct 1, 2014
Reaction score
Well, you appear to know quite a bit more about such situations than I, but perhaps a few questions and comments.

The upper case K seems to be normal.
Have you moved your user profile to another directory?
Malwarebytes does not show any problems on my system with a Firefox PUP involving the file you reference. Have you compared it to another system's pref.js file?

You have compared this system to your other systems for configuration differences? Do you have the ability to take this system to another location for testing or can you shutdown all the other systems and then reboot your system for testing?

I saw a post once where the user was showing a 1 hour lease on their network ... but your lease time is 24 hours or more?

Have you run a Wlan report and possibly compare it to one from another of your systems?

I don't suppose you found any related info on a Verizon site?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question