UWP app won't open after cloning Win10 install


Joined
Apr 9, 2020
Messages
1
Reaction score
0
I run a game server that uses a UWP app from the Windows Store. I've been operating it from a VM for a long time now but I've finally got an opening to move it to a physical machine. I've successfully transitioned the OS from the VM to a physical HD on a separate machine.

The issue I'm having is that no matter what I do, I cannot get the game app to open. It opened properly one time after I first cloned it, possibly before I connected to the internet but never since then. The first time I run the app after booting, it will sit on the UWP opening screen that has the app icon on a blue background for about 10 seconds then it closes. Anytime after that it opens to that screen for about 1 second then closes. I made sure the VM and newly cloned machine are never online at the same time.

These types of issues are immensely common with UWP apps and I've had this issue before when switching between copies of the same VM or switching Windows accounts. In the past I've gotten DCOM errors in the event log when dealing with this issue but not this time. When I boot the original VM up the app still works.

I've searched the web for anything that resembles a solution to this issue and nothing I've tried has fixed it. Here's my list of failed attempts:

-Made sure date/time is set automatically

-Ran WSReset

-Redownload/reinstalled the app (all 100gb+ -_-)

-Reset the game app and windows store app in Programs and Features

-Deleted temp files at C:\Windows\SoftwareDistribution\DataStore and \Download (the ones it would let me delete)

-Ran the Windows Store apps Troubleshooter

-Reinstalled Windows Store via PS command

-Cleared the LocalCache folder for Store in %localappdata%

-Reset the ACL's on the WindowsApps folder using "icacls" commands

-Set the new PC to run limited licensed content offline in Store settings

-Ran "DISM" and "sfc scannow" commands (neither found any issues)

-Logged in with local admin account and then back in with Microsoft account

-Spoofed the MAC address to match VM and changed PC name

-Reboot reboot reboot

I don't completely understand the way the licensing for WS apps work but this feels like some kind of licensing issue. There aren't really any errors in the event log that correlate with the app crashing as I had experienced with the DCOM errors in the past. I'm running out of ideas. Its difficult to grasp what is going with these UWP apps since MS keeps them so locked down.

Is there anything else I can try to resolve the issue?

OS: Windows 10 Home Edition x64
Winver: Version 1903 (OS Build 18362.720)
 
Ad

Advertisements

Ad

Advertisements

Joined
Jan 27, 2016
Messages
793
Reaction score
78
powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.XML

Clear Store Cache for Default Apps

1. Press the Windows+R keys on your keyboard to open the Run dialog.

2. Type WSReset.exe, and click/tap on OK.

all should not be restored to work
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top