Windows 10 Display/GPU/Driver Issues (RTX 3070)


Joined
Nov 21, 2020
Messages
7
Reaction score
0
Hello.

I recently built a new computer. My display is showing grainy colours along with fuzzy images and and jaggy text. I believe it is running Microsoft Basic Display Adapter even after downloading and updating the latest drivers.

Despite installing all of the latest drivers from the manufacturer's website, trying different cables (both HDMI and DC), and even changing display monitors, the problem persists. I have tried all the obvious troubleshooting methods such as reinstalling drivers, a fresh installation of windows, windows update etc but nothing has worked. When I open Windows device manager, it recognises the 'NVIDIA RTX 3070' as my display adapter, yet, I am left with a sub par visuals. The most interesting part is I can run games no problem, very smooth, at high settings across the board. I can still notice even in games that the text is jaggy and the visuals are slightly grainy and fuzzy.

It seems that from installing Windows from fresh, despite downloading the latest NVIDIA driver, there is no change in my display apart from a minor adjustment in resolution. The visuals are the same from a fresh reset to after downloading all the NVIDIA latest drivers and software.

Any thoughts would be highly appreciated!

I am running...

AMD Ryzen 3900 XT 12 Core
Vengence 2 x 16GB Ram
ASUS ROG STRIX 570-i Motherboard
Gigabyte Gaming OC Nvidia RTX 3070 GPU
Windows 10 Pro
1 M.2 Samsung 500GB SSD
1 M.2 Samsung 2TB SSD

Monitor MSI Optix G24 Series (currently using DP cable and have tried HDMI).
 
Ad

Advertisements

Joined
Apr 22, 2017
Messages
5,037
Reaction score
639
Hi skennysk,

first check Settings > Display and make sure it is using the recommended settings, second, press the menu button on your monitor and look for the Reset function and reset it, it may be tuned to your previous GPU?. :)

1606114927836.png
 

bassfisher6522

Moderator
Joined
Sep 22, 2014
Messages
1,962
Reaction score
375
Also, look into your BIOS to make sure that the onboard GPU is disabled and that the PCIe slot 1 is set to auto or enabled depending on mobo brand.

Then make sure you have Gigabytes GPU software installed to setup the fan curve for your GPU. It's called the Aorus Engine.

With this new build....did you do a clean install of the OS or move over the OS that was on another HDD/SSD? When doing a clean install make sure that any other drives in the system are disconnected.
 
Joined
Nov 21, 2020
Messages
7
Reaction score
0
Hi skennysk,

first check Settings > Display and make sure it is using the recommended settings, second, press the menu button on your monitor and look for the Reset function and reset it, it may be tuned to your previous GPU?. :)

View attachment 12740

Hi. Thanks for your reply - much appreciated. Unfortunately, I have exhausted both of these methods and almost every other troubleshooting method similar, including display collaboration etc. I also tried a second monitor with the same issue. The problem I face is no change in graphics, apart from resolution, after installing the new graphics driver. Thus, I can run games but one can notice incorrect and blotchy colours/grainy video cut scenes etc.
 
Joined
Nov 21, 2020
Messages
7
Reaction score
0
Also, look into your BIOS to make sure that the onboard GPU is disabled and that the PCIe slot 1 is set to auto or enabled depending on mobo brand.

Then make sure you have Gigabytes GPU software installed to setup the fan curve for your GPU. It's called the Aorus Engine.

With this new build....did you do a clean install of the OS or move over the OS that was on another HDD/SSD? When doing a clean install make sure that any other drives in the system are disconnected.
As far as I'm aware there is no on board GPU. Certainly from the outset I was never able to plug a HDMI cable into the motherboard and receive a signal. I previously tried this method in the Bios, however, it only detects a GPU in the PCI slot, therefore, giving me no option to disable any onboard GPU.

Unfortunately, I have downloaded the driver from that website address. I did just download the Aorus Engine - does this look okay?

It was a clean install. Every component was fresh out the box. I installed the new OS onto the 500 gb M.2 drive straight from a Windows 10 Official Pro USB boot.
 

Attachments

  • Untitled.jpg
    Untitled.jpg
    359.8 KB · Views: 61
Joined
Nov 21, 2020
Messages
7
Reaction score
0
Are you able to see the jagged/pixelated icons on my desktop in the image? As I said, this turns into grainy video/colours in video and games despite running very smoothly.
 
Ad

Advertisements

Joined
Apr 22, 2017
Messages
5,037
Reaction score
639
ASUS ROG STRIX 570-i Motherboard
What country are you in?, I cannot find this model but it might have 2 PCIe sockets?, do you have it in the top one when you look at the mobo from a side view?. :)
 
Joined
Nov 21, 2020
Messages
7
Reaction score
0
Ad

Advertisements

Joined
Apr 22, 2017
Messages
5,037
Reaction score
639
The only three things I can think of is that the drivers are not working correctly or the GPU is not seated in the PCIe slot correctly?. There is also the possibility that there might be dust or dirt on the GPU contacts???. I would remove the GPU and reseat it but cannot say whether or not that will help?. :)
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top