Windows 10 Idle timeout


Joined
Oct 28, 2019
Messages
3
Reaction score
0
Hi guys,
So, I have tried many things already within my knowledge to prevent this from happening but nothing helped. The issue is after a certain amount of idling time the computer goes to the lock screen. The idea is not to disable the lock screen which I already know how to do but to delay to stop the PC from idling and ultimately bringing me back to the lock screen. Just to clarify, it isn't going to sleep I did everything to make sure it isn't a power options issue of it going to sleep. I set everything to never. I even changed up the registry for the display settings in the power options "Console lock display off timeout" I have set that 0 minutes because everywhere else says "0" disables it from turning the display off and for the Sleep settings I have added the registry setting to give me the option of changing the "idle time out" and I have set that to never.

But after all that setting all sleep settings to never the screen still idles and sends me to the lock screen after a certain period.

If you need any more clarification let me know.

Thank you,
 
Ad

Advertisements

Joined
May 6, 2015
Messages
2,452
Reaction score
380
Interesting. My PCs are all set to never turn anything off, never to sign out and they stay on all day.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,368
Reaction score
1,042
Hi and Welcome to the Forum.

Idling time is controlled via Screen saver settings:
  • Click Start | Settings cog | Personalization
  • On the left panel select Lock screen
  • On the right panel scroll down a little then click the hyperlinked: Screen saver settings
  • Check the box next to: On resume, display logon screen
  • Now adjust the Wait time then click Apply
 
Joined
Oct 28, 2019
Messages
3
Reaction score
0
Hi and Welcome to the Forum.

Idling time is controlled via Screen saver settings:
  • Click Start | Settings cog | Personalization
  • On the left panel select Lock screen
  • On the right panel scroll down a little then click the hyperlinked: Screen saver settings
  • Check the box next to: On resume, display logon screen
  • Now adjust the Wait time then click Apply
Hi regedit32,
I will give that a try. I'll update you guys on here. Thanks.
 
Joined
Oct 28, 2019
Messages
3
Reaction score
0
Hi guys,
I have tested it out and it is still idling too soon. I probably should have given this information sooner. So, what I'm really trying to accomplish is we don't want it to idle and lockout too soon. We want it to stay at the desktop screen for at least 8 hours because the PC I am trying to do this on for displaying stuff. Yes, this is a work-related matter and no there are no restrictions since I am ultimately the admin in the department. Thanks again, guys.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,368
Reaction score
1,042
Ahh ok, I'm beginning to get a clear picture of what you are trying to do:

As you have probably already discovered, when you click Start | Settings cog | System | Power & Sleep, you are limited to a maximum of 5 hours, or choosing Never, but in your case you are wanting to set it to 8 hours [ i.e. a finite period of time ].

To be able to do that, you'd need to modify the Registry first, then via Control Panel | Power Options, change the power plan.

This would be a way of achieving this:
  • Press Windows key once to give focus to the Cortana Search box
  • Type cmd, then press Ctrl + Shift + Enter keys together simultaneously
  • The User Account Control will pop up. Click yes to allow an elevated Command Prompt to open
  • At the command prompt type the following command:

    Code:
    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7" /v Attributes /t REG_DWORD /d 2 /F
    Press Enter key to execute the command.

    Type exit then press Enter key to close the elevated Command Prompt

  • Next, press Windows key once to give focus to the Cortana Search box
  • Type Control Panel then press Enter key
  • When the Control Panel opens select to view by large or small icons
  • Select Power Options
  • To the right of Balanced (recommended) click the hyperlinked: Change plan settings
  • On the next screen, click the hyperlinked: Change advanced power settings
  • In the Power Options dialog that opens, scroll down and expand Display by clicking the + symbol next to Display
  • The Registry modification you made via the elevated Command Prompt will allow you to see a new option for the Console.

    Click the + next to Console lock display off timeout to expand it

  • Now click on the 1Minute to the right of Setting: and adjust accordingly [ e.g. 480 Minutes ]
  • Finally, click Apply, then click OK

    Sample image


    Console.png

Note:

On a standard Windows 10 installation, the Console lock display off timeout option is not present. To add this option, you modify the Attributes value on the following path:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7

The default Data value for Attributes is 1, but by modifying this data value to be 2 allows you to see the Console lock option.

To reverse the Modification made, simply repeat the initial steps above in an elevated command prompt, using the following command:

Code:
reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7" /v Attributes /t REG_DWORD /d 1 /F
Regards,

Regedit32
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top