Windows Explorer 'Desktop' icons


Joined
Jan 21, 2020
Messages
6
Reaction score
0
I have Windows 10 64-bit updated. When I open Windows explorer I see 2 icons for 'Desktop' (see attached screenshot). Both navigate to the same place although the icons are different. I suspect this is because I recently redirected the Pictures library to the desktop and then deleted all the native Picture library folders - so the default folder for saving all images is now the Desktop, which is what I want. Is there an easy way to get rid of the second icon. I have already unchecked 'Show libraries'.
 

Attachments

Ad

Advertisements

Joined
Apr 22, 2017
Messages
2,862
Reaction score
339
Hi perkin5,

what happens when you right click the desktop icons?, do you have the option to delete them?. :)
 
Joined
Jan 27, 2016
Messages
459
Reaction score
27
You might try
1. drag to recycle bin (best option)
2. right click and unpin
3. right click and open location and see exactly where it takes you.... if a genuine shortcut
you should see in properties.
 
Joined
Jan 21, 2020
Messages
6
Reaction score
0
You might try
1. drag to recycle bin (best option)
2. right click and unpin
3. right click and open location and see exactly where it takes you.... if a genuine shortcut
you should see in properties.
Both the desktop links navigate to the same Desktop folder. Don't know what you mean by unpin - not pinned to anything
 
Ad

Advertisements

Joined
Nov 28, 2015
Messages
92
Reaction score
11
This might be something. Click on Libraries. Then right-click on the Desktop folder with the pictures icon and select Properties. See the attachment from my computer. I have a green check mark next to the location for my Pictures that I redirected to the E:\ drive. If you have a check mark next to the Desktop folder instead, maybe it has no choice than to use Desktop as the name.
 

Attachments

Joined
Jan 21, 2020
Messages
6
Reaction score
0
This might be something. Click on Libraries. Then right-click on the Desktop folder with the pictures icon and select Properties. See the attachment from my computer. I have a green check mark next to the location for my Pictures that I redirected to the E:\ drive. If you have a check mark next to the Desktop folder instead, maybe it has no choice than to use Desktop as the name.
Sadly that didn't work for me. When I did exactly as you suggest I got the attached screenshot. Both these Desktop icons appear to point to the same Desktop folder - like having 2 html links pointing to the same place. I suspect I need to amend the Registry but am not confident enough to do this without expert guidance
 

Attachments

Joined
Nov 19, 2013
Messages
4,765
Reaction score
927
See if you can delete them from
C:\Users\username\Desktop
and
C:\Users\Public\Desktop
 
Joined
Nov 28, 2015
Messages
92
Reaction score
11
Sadly that didn't work for me. When I did exactly as you suggest I got the attached screenshot. Both these Desktop icons appear to point to the same Desktop folder - like having 2 html links pointing to the same place. I suspect I need to amend the Registry but am not confident enough to do this without expert guidance
It makes sense that your Desktop is also your Pictures library as you mentioned in your first post, so the shortcuts would point to the same place (your Desktop).

In the file manager view, under the User heading (see attached), if you right-click on the 'Desktop' folder with the pictures icon, can you select "Rename" and change the name from "Desktop" to "Pictures"? Otherwise, then you might have to create an actual 'Pictures' folder on your desktop and make that your Pictures library location, since you want to make the Desktop the library location for your Pictures. The library wouldn't be at the main desktop level, but this new sub-folder within it.
 

Attachments

Ad

Advertisements

Joined
Jan 21, 2020
Messages
6
Reaction score
0
See if you can delete them from
C:\Users\username\Desktop
and
C:\Users\Public\Desktop
No this doesn't work. Inside the C:\Users\Public\ folder there is no Desktop folder - only one called Public Desktop which has no content. the C:\Users\username\Desktop folder is there but of course I don't want to delete that as it has some content that I want to keep
It makes sense that your Desktop is also your Pictures library as you mentioned in your first post, so the shortcuts would point to the same place (your Desktop).

In the file manager view, under the User heading (see attached), if you right-click on the 'Desktop' folder with the pictures icon, can you select "Rename" and change the name from "Desktop" to "Pictures"? Otherwise, then you might have to create an actual 'Pictures' folder on your desktop and make that your Pictures library location, since you want to make the Desktop the library location for your Pictures. The library wouldn't be at the main desktop level, but this new sub-folder within it.
I get your point but when I right-click on the 'Desktop' folder with the pictures icon I do not get a rename option. I did try creating a pictures folder in the desktop but Windows then tried to put my entire desktop into it, blanking the default desktop, and it took me quite a while to restore the status quo. I'm thinking I'll just leave it the way it is!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top