Any way to disable or turn off automatic updates?

May 5, 2019
Reaction score
Hi Folks,

My Dell laptop displays some decidedly strange behavior, centered around Windows Update. I have all "sleep" and suspend settings set to "OFF" when the laptop is plugged into AC. I've blown out the drive (choked with Dell bloatware) and done a clean install of Windows 10 (dual-boot with Linux Mint). I generally just leave the thing on at all times... just close the lid and set it aside until tomorrow... I don't like long waits for bootup. Several times now, I've picked it up not very long after using it previously, opened the lid... and got nothing. Black screen. Fan is still spinning (quietly), power LED is lit, but otherwise it appears dead. Hitting 'enter' or 'esc' or clicking the touchpad does nothing. Poking the power button also does nothing. It's utterly unresponsive. Finally have to hold the power button down until it powers down, then restart. Then I'm looking at a "do not turn off your computer" while it's processing updates, then, eventually, it restarts and I'm back into Windows... at which point my browser gets snippy at me about improper shutdown and has to restore all my open tabs.

So, is there any way to turn off automatic updates? I generally prefer to deal with updates at a time of my choosing, rather than having Windows barge in like the PC belongs to Microsoft, not to me. Or maybe to at least prompt me about updating to see if now's a good time, or something like that?

Thanks for any advice!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question