Back button doesn't show search results screen.


BML

Joined
Dec 19, 2015
Messages
163
Reaction score
4
When I used to key a subject into Google I used to be able to hit the back button and start looking again. This stopped a week or so ago possibly after checking and downloading some updates. I know it only takes a few seconds to start searching again but at 80 years of age I'm running out of the seconds I have left and its very frustrating. Can anyone offer a way to resolve this matter?
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,169
Reaction score
991
I assume you are using Google Chrome browser to do your Google Search.

What build are you using? The latest build is: Version 59.0.3071.115 (Official Build) (64-bit)
  • You can check by clicking the 3 vertical dots on top right side of browser, then select Settings
  • In the window that opens, in top left click Settings then click About Chrome
  • If its not up to date, it will automatically download the latest build.

I checked my own Chrome, but also checked using Google Search in Microsoft's Edge browser too, and both worked fine in the following scenario:
  • Entered a topic in search field
  • Pressed Enter key
  • Pressed backspace key
I could also press backspace key before pressing Enter to initiate the search​


If you are all ready on the latest build of Google Chrome, then perhaps resetting settings to default status would overcome the issue. To do that:
  • Click the 3 vertical dots in top right side of browser, then select Settings
  • In the window that opens, in top left click Settings
  • Click on Advanced then click Reset
 

BML

Joined
Dec 19, 2015
Messages
163
Reaction score
4
I followed your instructions and thank you very much because I can now use the Back Button. This appears to me that Google messed it up thereby forcing its users to move onto Google Chrome.
I now have a supplementary little problem in that I can't find mu favourites.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,169
Reaction score
991
I now have a supplementary little problem in that I can't find mu favourites.
Click the 3 vertical dots in top right side then select Bookmarks
  • Favorites is called Bookmarks in Google Chrome
You can also use your Keyboard shortcuts:
  • Ctrl + Shift + B makes Bookmarks appear in the toolbar below Address bar
  • Ctrl + Shift + O opens the Bookmarks Manager in the top left corner where you'll be able to see your individual folders, and bookmarked sites
  • For a complete list of keyboard shortcuts:
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top