Cannot change default program via the Settings menu (can via Control Panel)


Joined
May 15, 2016
Messages
1
Reaction score
0
So basically my issue is the same as this guy's:
https://www.windows10forums.com/threads/cannot-select-default-browser.8589/

I installed Vivaldi yesterday, there are three options to install it:|
1. just for me user\appdata
2. for everyone \program files\
3. standalone \program files\

Since both 2. and 3. installed into \program files\, I wanted to see what the difference is, so I chose 3. The browser installed, but no Start Menu or desktop shortcuts were created, I had to do it on my own. I've set Vivaldi as my default browser and it was OK, later that day I decided I don't want it and will probably go back to Chrome, so I have this program IObit Uninstaller that handles my uninstalling, because with one double click it uninstalls the program and searches for leftovers/residual files/whatever.

I looked for Vivaldi there, it wasn't there, I tried the Add/Remove program which is part of Settings, but Vivaldi wasn't present there either. Since I was playing an online game at that time, I forgot to check the Add/Remove of Control Panel, so I manually Shift+Del-eted Vivaldi's installation folder (for reference I had Vivaldi open, I opened Task Manager and found the process then I pressed Open File Directory, backed up a bit and deleted it)

Now I installed Chrome again and when I want to set it as default browser, I get the exact same issue as this other guy, whose thread I linked.

I tried the following:

1. Restart Explorer.exe
2. Restart Windows
3. Clean and Defrag registry with Wise Registry Cleaner and manually deleting anything "Vivaldi" from regedit.exe
4. pasted this in Power Shell (as Admin): Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}

After all this and restarting Windows a couple of times, I still can't get the Settings thing to work.

I looked for restore points prior to this, but I have none. The only solution I can come up with is reinstalling, but this is a huge hassle and everything else is working fine. I know I can use the old method (Control Panel) to get the job done, but I don't find this as a complete solution and I'm looking for a way to make it work once again via Settings)

Most of my gripes with Windows 10 have been with parts of the UI based on this Modern/Metro language, once they screw up and I can't even open my start menu or even the taskbar doesn't work, I have to reinstall.

Does anyone have another solution? Thank you.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,196
Reaction score
996
Hi Lamda471,

I've just finished posting a Registry tweak that can resolve the situation you are experiencing.

See here: https://www.windows10forums.com/threads/cannot-set-default-web-browser-except-edge.8952/page-2#post-40861

If you choose to go down this path:
  1. Read the entire post carefully
  2. Make the recommended Restore point first!
  3. Please use caution when working in your Registry Editor

Alternatively, you could do an in-Place upgrade that may resolve this.

If you are wanting to do that, then let me know and I'll provide instructions on how to do this.

Regards,

Regedit32
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top