Cannot set default web browser except edge.


Joined
Nov 19, 2013
Messages
4,554
Reaction score
886
If not too private, could you paste a copy of your Taskmanager - Startup window or, copy the programs to this thread, that you have running there?

More thoughts. Two common factors, which may cause the problem. I am still thinking third party. In this respect, I would regard Bing as a suspect. In edge, and Chrome, make sure you have another search engine as default (Google?). Another is Cortana. Disable it , at least temporarily, and see how that goes.
 
Last edited:
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
I have tried anothe local admin accout too. Same issue..
There is no ProgId in the reg. This mashine is a Win10 home.
Hi Irylen,

The Hash strings for each Program and/or file extension assigned to them are assigned by Microsoft's built in algorithm. They are created using a mix of the Computer name, The Application's name, and the Current Username (i.e. the name of user logged into System).

In theory you could probably calculate this HASH algorithm output and manipulate things, but given Microsoft assigned Special permissions to these Keys that would not only take much effort and time, but could potentially if done wrong corrupt the System and in a best case scenario may prove to be unstable anyway.

Microsoft is using these Hash strings to prevent internal manipulation of the UserChoice. Thus, if you for example went to HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.pdf\UserChoice and then manually Modified the Hash and/or ProgID String Data Values, if the Defaults are Microsoft's recommended App (in this case Microsoft Edge) you will discover you cannot change the keys Data values as this alert will pop up:

Error Editing Value.png


If on the other hand you via GUI Default Programs had chosen Acrobat Reader and this had successfully worked, you can Modify both the Hash and ProgID strings internally. Then the catch-22 strikes! As soon as you then attempt to open a PDF document Windows detects the change and the alert Irylen has been getting appears and Microsoft Edge is automatically set to Default app to handle the request.

App Default Reset.png


This is where you start going ᕦ(ò_ó*)ᕤ or if you're more chilled ¯\_(ツ)_/¯ or maybe you just give up ٩(͡๏̯͡๏)۶

All perfectly human responses to a technical nightmare especially if you're trying to setup multiple users in a company. Fortunately, despite all this Microsoft did provide a few ways in (at least they have for now - that may change yet.)

While you cannot delete the Hash or ProgID, or modify it internally, you can delete the entire subkey .pdf, then write your own REG file and merge her in ('it in' if you feel the need for political correctness at this point :rolleyes: )

Note though: if you attempt to merge said file before deleting the existing subkey Special permissions will prevent the action taking place.

Getting back to your quote Irylen
- it is highly unusual that no ProgID is present when you queried those keys given you previously stated you had see such an App default was reset alert. This should have automatically written to the Registry key the ProdID for your Microsoft Edge browser.

Given that has not taken place I must confess I am now even more so leaning to both daveHC's comments and Troubles on this thread. You either have some third party utility actively trying to override the Special permissions built in, or your Profile is somehow corrupted - hence Troubles suggestion about creating a new Profile and testing whether the situation continues. If a new Profile also fails, then the problem is Global and that may mean doing an in-Place upgrade of the Windows OS to rid yourself of the issue once and for all.

One other possibility is we can consider editing the MicrosoftEdge key in the Classes hive. If this fails though you will need to either find the third party utility causing the issue and remove it, or consider the in-Place upgrade.

This will need to be done manually as I cannot control the HASHing code from my end as this is generated within your System based on your Computer name, your username, and the Program name.

If you are going to attempt this please first Create a Restore Point:

  • In your Search/Cortana box type Create a restore point then press Enter
  • In the window that opens:
    1. Verify System Protection for your partition windows is installed on is turned on
    2. Click Create button and follow prompts

Sample image below to demonstrate what I am talking about

System Properties.png


Once and only if you have a new Restore point created then you can try the following in your Registry.

  • Press Winkey + R to open Run Dialog
  • Type regedit then click OK to open your Registry Editor
    • Note: If prompted by User Account Control click Yes
  • In the left pane of Registry Editor you need to Expand the Keys to following location:

Code:
HKEY_CURRENT_USER
  > SOFTWARE
    > Classes
      > Local Settings
        > Software
          > Microsoft
            > Windows
              > CurrentVersion
                > AppModel
                  > Repository
                    > Packages
                      > Microsoft.MicrosoftEdge_25.10586.0.0_neutral__8wekyb3d8bbwe
                        > MicrosoftEdge
                          > Capabilities
                            > FileAssociations
Note: That Microsoft.MicrosoftEdge_25.10586.0.0_neutral__8wekyb3d8bbwe subkey above may have a different version number subject to what build you are using at the moment.

There should only be one Microsoft.MicrosoftEdge_XXXX_neutral__8wekyb3d8bbwe (where XXXX is the version number) key present though so if it differs simply expand that one and continue to FileAssociations as above.

  • Once you get to FileAssociation key left-click on the key to view its contents in the right pane

The image below is what you should be seeing. Note the status bar at bottom of registry window confirms your current location. Make sure it is where I told you to be.

FileAssociations.png

  • In that right-pane take a close look at the String: .html and its Data Value

    In the image above you can see the Data Value is: AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9
  • That Data Value is important so make a note of it now.

    You could if you want to right-click on .html and select Modify. The window that opens will by default have Value Data highlighted. Simply press Ctrl + C to copy it, then click Cancel button and open a Notepad and paste it there by pressing Ctrl + V.
  • Ok with this information noted we need to return to left pane and navigate to a new location
  • In between the left and right panes click the Vertical slider and slide to TOP so that in the left pane you can see:
Computer
> HKEY_CLASS_ROOT
> HKEY_CURRENT_USER etcetera​

  • Now in left pane you need to expand keys to the following location:

HKEY_CURRENT_USER
> SOFTWARE
> Classes
> AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9
Note: Assuming you and I are using the same build of Microsoft Edge you more than likely have the same Data Value and will hence end up at this same identical folder. If your Data Value was different to mine earlier, then it is that subkey you need to go to under Classes above.

  • Left-click on AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9 to view its contents in the right pane

    You ought to see the following

    App Default Reset 2.png

  • In the left-pane you need to:
    • Right-click on AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9
    • Select New > String Value
    • In the right pane you will now see another ab string called New Value #1
      • Right-click on New Value #1
      • Select Rename
      • For the new name type NoOpenWith then click away from String to remove focus so the new name sticks.
      • Press F5 key to refresh registry

You will now see this if done correctly:

App Default Reset 3.png



  • So long as you are certain PDF files are not the cause of your issues you can close the Registry Editor window now. If it is at all possible it is the PDF file extension giving you the issue, then you can do the same steps above but you would be seeking the .pdf Value Data information so you can add the NoOpenWith string to the correct subkey.
  • If you are ready then close Registry Editor window now
Finally, we return to where it all began. Setting Default Programs.
  • Click Start > Settings > System > (in the left pane) Default apps
  • In the right pane under Web browser a change

    The change!

    App Default Reset 4.png
  • If you click Choose a default you will see another change!

    App Default Reset 5.png
  • As you can see you no longer have Microsoft Edge listed. Only any other browser currently installed on your computer under your username you are logged in with. Select the one you want.
  • Happy Default Browsing :)

Final notes:
  1. If you suddenly change mind and wish you still could default to Microsoft Edge:
    • Right-click Start > Control Panel > Default Programs
    • Click Set you default programs hyperlink. Microsoft Edge is listed here still.
  2. Watch out for the next Microsoft Updates. Or if you do an in-Place Upgrade, or Clean Install, or Reset this PC, etcetera. All these actions will overwrite the Registry removing your modification. You'd then need to redo the modification if whatever is truly causing your current issue has not been resolved.
  3. COPYRIGHTS © 2016: This NoOpenWith tweak was created by Ramesh Srinivasan, former Microsoft MVP for Windows Desktop Experience. He has granted me permission via e-mail to post the relevant Registry tweaks here to help resolve this issue. Should anyone else view this content and wish to post it elsewhere online they must obtain Rameshs' permission to do so, otherwise they could face a REMOVAL order and any other legal actions available under his Copyright arrangements. Should you wish to obtain this permission send me an Inbox request for contact details for Ramesh.
OK, if you have not all ready fallen asleep reading this.

Happy Computing.

Regards,

Regedit32
 
Joined
May 14, 2016
Messages
16
Reaction score
0
Hello Regedit32, thank you for your big effort to help me out. I think I am driving you nuts. But all the changes made Edge to dissapear but it still wants med to choose default web browser every time. I can neither make .htm or .html permanent associated with any browser. I always have to choose one. I checked the pdf and that is set to Adobe and can be changed if I whant. So still I don't know what to do. I have disabled McAfee and no change. So is the only way to reinstall? I have made the installation from 8.1 and don't have any media to install from.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
Hi Irylen,

I've applied the same method to my own machine to ensure I did not miss type any of my instructions.

When you click Start > Settings > System > (in left pane) Default apps do you see now in the right pane under Web browser a grey + and the wording Choose a Browser?

This will remain so until you choose an installed browser on your System, be that Internet Explorer, Chrome, Firefox, or some other browser.

I left it like this and began opening the handful of browsers I've installed to test this. Each one when I opened it asked me if I wanted to make it the default browser. I ignore those requests.

I then return to the Default apps window, and chose Chrome as a default browser. Its logo now displays beneath the Web Browser heading. I then re-opened each of my test Browsers I've downloaded. All but one opened normally and made no request to become the Default Browser. Ironically, the one that did ask was Google Chrome. I again ignore its question, closed the browser then re-opened it. The second time it did not ask me again as I assume it finally realized it is all ready the Default browser.

Can you confirm which browser you are now trying to make Default. Is it listed when you go to the Default Apps window via Start > Settings > System > Default apps and click Choose a default or if a browser is all ready listed there. if you click on the browser, can you then choose an alternate one.

Can you also confirm Microsoft Edge is no longer an option there when you want to choose a default app.

While we are checking things, can you also:
  • Right-click on Start
  • Left-click on Command Prompt (Admin)
  • Type or Copy & Paste the following into the Administrator: Command Prompt window:

    reg query HKCU\SOFTWARE\Classes\AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9

    Note: If you paste this into Command Prompt be careful a ? does not sneak on end of command making it appear in the Command Prompt looking like:

    reg query HKCU\SOFTWARE\Classes\AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9?

    Press Enter key to execute above command

    Image displaying what ought to be typed or pasted as command and the result you ought to get:

    Example.png
  • Is the NoOpenWith present?

Regards,

Regedit32
 
Joined
May 14, 2016
Messages
16
Reaction score
0
Exactly! This is my settings.
Microsoft Windows [Version 10.0.10586]
(c) 2015 Microsoft Corporation. Med ensamrätt.

C:\WINDOWS\system32>reg query HKCU\SOFTWARE\Classes\AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9

HKEY_CURRENT_USER\SOFTWARE\Classes\AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9
NoOpenWith REG_SZ

HKEY_CURRENT_USER\SOFTWARE\Classes\AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9\Application
HKEY_CURRENT_USER\SOFTWARE\Classes\AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9\DefaultIcon
HKEY_CURRENT_USER\SOFTWARE\Classes\AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9\Shell

Edge is not available as default and I dont get the question if I want this as default when I open the browsers BUT when I click a link I get "which one do you want to open with" and I still can't set default http ann https default app. And the +-sign on default web app is still standing and cant be changed. I am trying to default "Firefox".
As I'm in Sweden i'm going to bed now and I'll se tomorrow if you have any idea.
Thanks
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
What language pack is installed for your Windows 10 OS?

When you open Registry Editor are the various keys and information inside the keys you choose to view contents of using English or another language?

I ask as the editing I got you to make when you added the NoOpenWith String to that subkey may need to be entered in the System language you are actually using.

I don't speak Swedish per se so don't take this as verbatim, but perhaps that NoOpenWith needs to be:
  • IngenÖppnaMed
  • Blame Google Translate is that makes no sense :D

I'll wait till you reply with the System Language you are using as main choice, before going any further.

Regards,

Regedit32
 
Joined
Nov 19, 2013
Messages
4,554
Reaction score
886
I could just horn in again and confirm. In my environment (Denmark) I have computers running with that language as the operational interface. registry/dos commands..etc.. are all remaining in English.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
I could just horn in again and confirm. In my environment (Denmark) I have computers running with that language as the operational interface. registry/dos commands..etc.. are all remaining in English.
Thanks Dave,

I appreciate the feedback there.
 
Joined
May 14, 2016
Messages
16
Reaction score
0
Yes, I'm using the swedish language set, but keys are in english. It works so far that Edge dissapears as optional but I can't still set the default browser. Funny is that so far I can see all other app can be set to all other extensions except htm and html. Neither can I set default to http or https.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
When you select the Default Browser after editing the Registry as you did you need to do it via Settings panel;
  • Start > Settings > System > (in the left pane) Default apps > in the main window under Web Browser click Choose default > then from pop up select a Browser
If you attempt to set a default by some other means you may corrupt the Registry again, which appears to be what led us to doing this radical tweak in the first place.

I've tested this Tweak with multiple browsers now and all worked fine, except Chrome that I had to set it twice (not sure why) but the second time it became default.

Regarding the System language; daveHC responded as he is in Denmark using Danish and he noted the Registry is still in English too. It was just an afterthought I had; but it appears that tweaking in English is fine in this instance.
 
Last edited:
Joined
May 14, 2016
Messages
16
Reaction score
0
I do exactly wat you say and have done so all the time, but still the same result. And I have tried to choose standard app after file-type with the same result.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
Hmm,

So when you edited the Registry with that NoOpenWith string you only edited the one key for your browser - is that correct? Or did you modify some other keys too like the PDF one?

Also, just for a test: if you click this URL > http://www.google.com/ what happens exactly?

Does it open inside a browser at all? Or do you get some error message and no browser opens at all?
 
Joined
May 14, 2016
Messages
16
Reaction score
0
Yes, it sent me to Google.com within my browser. But if i don't have a browser active it ask me wich on I want to use. So when I click the link in my mail I get the choise and if I click the link within Firefox it open a new page.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
What email client are you using?

Is it installed on your PC, or are you using it within a web browser?
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
Have you made Thunderbird your default mail client?

If not you need to so it integrates with other things including your choice of default browser to open links in

Start > Settings > System > [left pane] Default apps > [main window at top] Email

Is thunderbird there as your default?
 
Joined
May 14, 2016
Messages
16
Reaction score
0
Yes, it has been default for a long time since I installed Win10 on the release date. And I can tell you that both thunderbird and Firefox has been installed and defaulted all the time. Since some months ago this problem started and as I have automaic update I don't know exactly when. But it it is annoying and I thougt it was a overgoing problem, but not. It seems that several people has similar problem but not exactly the same.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,189
Reaction score
993
Hi Irylen,

OK so I have downloaded this Thunderbird Email Client and installed it so I could test it.
  • Parameters for my testing:
    • Default Browser: Firefox 46.0.1
    • Default Email: Thunderbird 45.1.0
    • Registry: Modified the registry by adding New > String: NoOpenWith to:
      HKEY_CURRENT_USER\SOFTWARE\Classes\AppX4hxtad77fbk3jkkeerkrm0ze94wjf3s9
  • Note: Both default settings were done via Start > Settings > System > (left pane) Default apps
    • i.e. When installing Firefox I removed check next to Make Browser Default and once installed and prompted within the Browser to set Firefox as default I rejected the prompt, closed browser and went to Start > Settings > System > (left pane) Default apps > (main window) Web browser and set it there. I did this to eliminate the chance a third party utility (i.e. Firefox) corrupted Registry through poor default extension handling.
    • When installing Thunderbird I did the same procedure as I did with Firefox, to eliminate any chance of corrupting the Registry through poor default extension handling.

Next with my parameters set so I could test things, I opened Thunderbird Email Client and just as you experience all the time I immediately got the alert about No Default Browser being set to open URL links.
  • I told it to use Firefox
  • I checked the Remember my choice for http links and clicked OK
  • The URL opened in Firefox
  • I closed both Firefox and Thunderbird
  • I re-opened Thunderbird, then opened a new email and clicked the URL. It immediately opened in Firefox with no warning to choose a browser.
  • Thus I can conclude now categorically the Registry Tweak and Thunderbird work fine together.


  • I then uninstalled both Firefox and Thunderbird, and then re-installed both programs.
  • I went to Start > Settings > System > (left pane) Default apps, and reset my Defaults to Chrome and Windows Live Mail
  • Next I installed Firefox but this time I allowed the installer to set Firefox as default (something I never do but needed to to test thoroughly).
  • I did the same with Thunderbird; allowed the installer to set Thunderbird as default.
  • Upon opening Firefox there was no alert to set it as default and it functioned normally.
  • Upon opening Thunderbird there was no immediate alert, but when I opened an email and clicked an URL, I did get an alert then to choose a browser. So I selected Firefox and checked the box again like in previous test.
  • The URL then opened in Firefox. I close both Firefox and Thunderbird.
  • I re-opened Thunderbird and went to a new email and clicked an URL. It opened immediately inside Firefox.
  • Thus I can conclude that the Registry tweak and allowing both Firefox and Thunderbird to automatically set themselves as default apps during installation works. (i.e. They do not appear to corrupt the Registry).
This got me thinking about what it is then that is preventing you having the same experience.
  • I re-opened Thunderbird and took a look behind the pretty GUI interface by doing the following:

    On the top right of Thunderbird's toolbar I clicked the icon with 3 vertical bars indicated in image below

    Thunderbird1.png


    This popped up two windows and I hovered mouse pointer on Options > which popped a tiny context menu over the top where I clicked on Options as indicated in image below

    Thunderbird2.png


    This opened a new Window which was set to Advanced Options and the General tab opened. There I clicked Config Editor ... button as indicated in image below

    Thunderbird3.png


    This opened a Splash window: This might void your warranty! I clicked the I'll be careful, I promise! as indicated in image below

    Thunderbird4.png

    And I was careful I promise o¿- *wink*

    This caused the about:config window to open with a long list of configurations. I've scrolled through these and found the ones that will be of interest for you. To save time I'll list the ones worth taking a peak at. You can enter them in the Search box at top of window to save scrolling.

    First you want to take a look at this one: network.protocol-handler.external-default

    Copy & Paste that into the search box and the window will display just that. Check it's boolean value is set to true. If it is false this will prevent URLS opening in an external handle (i,e, in Firefox browser). If it is false simply double-click on it to set it to true as indicated in image below:

    Thunderbird5.png


    OK if you had to reset that boolean value to be true then try now to open an email with an URL in it and click the URL to see whether or not it now opens in Firefox without prompting you to choose a browser.


    Note: As you did a reset you may get prompted the first time to choose browser. If you are then choose Firefox and place check in box next to Remember my choice for http links, then click OK. Try one more time to open an email and click an URL.

    If you are not prompted and all is well you can stop here. If its still prompting you then in that same about:config window check the following:

    Copy & paste the following into the about:config window's search box:
    • network.protocol-handler.warn-external.http

You will now see two entries in your window as in image below

Thunderbird6.png

Next copy & paste the following into the about:config search box:

network.protocol-handler.warn-external.ftp

See image below for details:

Thunderbird7.png
  • OK that is it. You can close this window now and close Thunderbird too.
  • Re-open Thunderbird and open an email with a URL inside it to click. You will be prompted to choose a browser - choose Firefox and make sure you put a check mark in the box next to Remember my choice for http links
  • Click OK

All going well that will be the LAST time you need to make that choice. To check whether we have finally resolved the issue. Close Thunderbird. Close Firefox. Now re-open only Thunderbird and try clicking an URL in an email now. It ought to open your Firefox browser now without asking for you to choose one.

Regards,

Regedit32
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top