SOLVED Computer administrator?


Joined
Nov 10, 2015
Messages
32
Reaction score
1
In the past, I moved the folder "Pictures" to a new location on Drive D. Today I returned it to the "default" Location. All went well.

I tried to delete "D:\Pictures" folder and got the message,

"You require permission from the computer's administrator to make changes to this folder"

1. I am logged in as an administrator
2. I successfully activated the net user administrator. That administrator gets the same message and cannot delete the folder.

What administrator account can delete the folder. How to I activate this administrator account?
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,214
Reaction score
1,000
Sounds to me like an ownership issue.

You may be able to resolve this using icacls in an elevated command prompt:
  1. Type cmd in your search bar
  2. From search results locate and right-click on Command Prompt then select Run as administrator
  3. When prompted by the User Account control, click Yes
  4. In the command prompt console type the following commands:

    Note: Be sure to include the speech marks and enter the exact path and folder name for the directory you intend to delete!

    The following commands assume D:\Pictures is the correct path and directory you wish to remove.

    Type or copy & paste the following at the command prompt:

    Code:
    takeown /F "D:\Pictures" /A /R /D Y
    Press Enter key to execute

    Type or copy & paste the following at the command prompt:

    Code:
    icacls "D:\Pictures" /T /grant administrators:F
    Press Enter key to execute

    Type or copy & paste the following to command prompt:

    Code:
    rmdir /s /q "D:\Pictures"
    Press Enter key to execute

All going well the folder will now be removed. You can type exit and press enter key to close the command prompt.

Regards,

Regedit32
 
Joined
Nov 10, 2015
Messages
32
Reaction score
1
Thank you for your response. I was not familiar with those commands. Unfortunately they did not work. Below is a copy of my effort:
I was logged in as an administrator and I did use the "Command prompt (Admin) window for the entries.
"
C:\WINDOWS\system32>takeown /F "D:\Pictures" /A /R /D Y
ERROR: Access is denied.

C:\WINDOWS\system32>icacls "D:\Pictures" /T /grant administrators:F
D:\Pictures: Access is denied.
Successfully processed 0 files; Failed processing 1 files

C:\WINDOWS\system32>rmdir /s /q "D:\Pictures"
Access is denied.

C:\WINDOWS\system32>

"
 
Joined
Nov 10, 2015
Messages
32
Reaction score
1
I switched users to another user with administrative privileges and ran your "takeown /F "D:\Pictures" /A /R /D Y "
command. As another user it allowed the action. I went back to my original user and simply deleted the Pictures folder.

Thank you. The problem is Solved
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,214
Reaction score
1,000
Glad it worked out for you.

Sorry, I forgot to mention you may need to us an alternate account. You worked that out for yourself though, so all ended well.
 
Joined
Nov 19, 2013
Messages
4,566
Reaction score
889
Try these. They make a small adjustment to your registry, which opens the folder/file security for Admin access.
Obviously, the first one is what you need. After completion, you can run the second, as a security precaution, to reverse the procedure.

Just agree to the two questions when you use the fix.
 

Attachments

Ad

Advertisements

Joined
Nov 19, 2013
Messages
4,566
Reaction score
889
Sorry. Should have added. After applying the fix, you can right click any folder/File and it will, under most circumstances, offer you the option
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top