Devices and Printers takes an age to load


Joined
Aug 2, 2016
Messages
2
Reaction score
0
Hi, I'm at my wits end and hoping someone here can help solve my problem.

I just upgraded to Win 10 pro (Vn 10.0.10586 Build 10586) from Win 7 Pro. I have spent a long time cleaning out upgrade bugs (mostly driver associated) but am left with one that's defeating me.

Devices and printers panel takes about a minute to load, sometimes longer, with a very slow green progress bar. When it opens all devices are there, and I have no issues with any of the devices. I have observed:
  1. Occasionally after a shutdown or restart, the D&P pane will load instantly, but after that it's slow again.
  2. In Win 10 settings > devices, all devices show immediately.
I could obviously just put up with it in the grand scheme of things, but I'm concerned that there is an underlying issue and Win 10 is not correctly hooked up. Any help appreciated, or if someone knows the processes/services involved in displaying D&P, I could carry on trying to find the fault. I read on another forum to delete the Device Stage folder, but that does not seem right to me.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,135
Hi Tamablaster,

Quick question for you: Do you have any Bluetooth devices connecting to your computer?
 
Ad

Advertisements

Joined
Aug 2, 2016
Messages
2
Reaction score
0
Hi Tamablaster,

Quick question for you: Do you have any Bluetooth devices connecting to your computer?
Hi Regedit32,

No, and I have switched off Bluetooth. I also stopped the Bluetooth Support Service, which some other folks were having issues with, but that made no difference either. Also tried disabling FW and AV, again no effect. Hope you can shed some light on this.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top