Firefox problems

Discussion in 'Software' started by Ghaeng, Jul 14, 2017.

  1. Ghaeng

    Ghaeng

    Joined:
    Jul 8, 2017
    Messages:
    15
    Likes Received:
    0
    I have a few problems with firefox...

    1. firefox is slow to start.. it takes 2-3 seconds for it to open from then i click on it on the taskbar.. i have already cleaned my computer from junk with wise cleaner..

    2. firefox doesnt show a list of websites that i have visited when i type the name of the website.. google chrome had a feature that would show a list of websites e.g. if you type windows10forums in the adress bar it would show this website

    3. firefox doesnt save logins.. it saves the passwords only but i have to go to the login tab and click on my username and click login everytime i visit a forum or a website.. i want to stay logged in..

    thanks
     
    Ghaeng, Jul 14, 2017
    #1
    1. Advertisements

  2. Ghaeng

    Norton

    Joined:
    Feb 18, 2016
    Messages:
    1,565
    Likes Received:
    301
    I have never had to log in or use a password with Fire Fox.
    When I open FF it goes directly to the selected home page of my choice.
    Click on the settings (hamburger) top right.
    Click on Options > Search and check the boxes "Provide suggestions and "Show search sugestions in location bar results. Next: click on Security >check "Remember Log Ins for Sites" and "Use Master Password"
    Is your browser up to date? Click on settings > Options > Advanced check Automatically Updates (recommended:improved security)

    Hopefully, that should solve your dilemma.
     
    Last edited: Jul 14, 2017
    Norton, Jul 14, 2017
    #2
    1. Advertisements

  3. Ghaeng

    Ghaeng

    Joined:
    Jul 8, 2017
    Messages:
    15
    Likes Received:
    0
    thanks, but unfortunately it didnt solve any of the problems.. yes its up to date and i have auto updates enabled
     
    Ghaeng, Jul 14, 2017
    #3
  4. Ghaeng

    Wolfie

    Joined:
    Apr 22, 2017
    Messages:
    590
    Likes Received:
    79
    Hi Ghaeng,

    when FireFox first starts, it searches for updates thus slowing it down a little.

    Check Security and Privacy settings for other possible solutions: :)

    firefox security.JPG


    firefox privacy.JPG
     
    Wolfie, Jul 15, 2017 at 5:22 AM
    #4
    davehc likes this.
  5. Ghaeng

    Ghaeng

    Joined:
    Jul 8, 2017
    Messages:
    15
    Likes Received:
    0
    checking history in privacy where it says location bar seems to solve problem 2.. thanks!
     
    Last edited: Jul 15, 2017 at 12:05 PM
    Ghaeng, Jul 15, 2017 at 11:58 AM
    #5
  6. Ghaeng

    Ghaeng

    Joined:
    Jul 8, 2017
    Messages:
    15
    Likes Received:
    0
    I still have problem 1 and 3... firefox now takes 6-7 seconds to start up from when i click on it on the taskbar and sometimes i have to click 3-4 times to start it... i cannot use my browser like this.. i have tried disabling addons/themes without luck.. the only thing i can think of is that firefox sometimes searches for previously opened websites and then tries to open them again.. maybe this is causing firefox to load slow.. is there any way to disable this feature?
     
    Ghaeng, Jul 17, 2017 at 6:37 AM
    #6
  7. Ghaeng

    Wolfie

    Joined:
    Apr 22, 2017
    Messages:
    590
    Likes Received:
    79
    Set it to "Never remember history" which might help?:

    firefox privacy 2.JPG

    Also, do you have the latest version?, click on "Help > About" and let it do its thing, it may be worth to note that FireFox updates in steps, if you are a few versions behind, you may need to do it a couple of times?. ;)

    Current version:

    firefox version.JPG
     
    Wolfie, Jul 18, 2017 at 5:58 AM
    #7
    Norton and davehc like this.
  8. Ghaeng

    Norton

    Joined:
    Feb 18, 2016
    Messages:
    1,565
    Likes Received:
    301
    What anti virus are you running.
     
    Norton, Jul 18, 2017 at 2:05 PM
    #8
  9. Ghaeng

    BigFeet

    Joined:
    Oct 2, 2014
    Messages:
    713
    Likes Received:
    113
    Location:
    Syracuse
    In settings, under the general section, make sure where it says "When firefox starts" is not set to "Show your windows and tabs from last time".
     
    BigFeet, Jul 18, 2017 at 5:49 PM
    #9
    Wolfie likes this.
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. george

    SOLVED Firefox and IE crashing in build 9879

    george, Dec 31, 2014, in forum: Windows 10 Support
    Replies:
    12
    Views:
    1,993
    george
    Dec 31, 2014
  2. Dipsy

    Firefox Users?

    Dipsy, Jan 27, 2015, in forum: Windows 10 Support
    Replies:
    4
    Views:
    807
    bassfisher6522
    Jan 28, 2015
  3. Duneman
    Replies:
    0
    Views:
    734
    Duneman
    Aug 5, 2015
  4. bassfisher6522

    Firefox

    bassfisher6522, Aug 5, 2015, in forum: General Discussion
    Replies:
    2
    Views:
    718
    BUNYIP BILL
    Aug 6, 2015
  5. folo

    Youtube in Firefox

    folo, Aug 7, 2015, in forum: Windows 10 Support
    Replies:
    3
    Views:
    948
    Davee3
    Aug 7, 2015
  6. Lori
    Replies:
    3
    Views:
    805
  7. Lori
    Replies:
    16
    Views:
    3,289
  8. Adela

    Problems with Firefox? WLMail? Plain Windows?

    Adela, Jan 4, 2017, in forum: Windows 10 Support
    Replies:
    0
    Views:
    143
    Adela
    Jan 4, 2017
Loading...