SOLVED How do I disable lock screen after Anniversary update?


Joined
Jul 26, 2015
Messages
56
Reaction score
6
When I start up my lap top after the Anniversary Update it has once again the lock screen. It has that picture of the sea and rocks etc. All I need to do is click it and it disappears .. but I don't want the nuisance lock screen. I don't have a touch screen, I still use my mouse and pad. This lock screen is just another click I have to do to get started. Can any one help me on how to disable the lock screen.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,130
Hi acerguy,

With the Anniversary Update Microsoft chose to remove the Group Policy option to disable the Lock Screen for Windows Professional Users, and also for those who have unofficially installed the Group Policy Editor onto their Windows 10 Home edition (which by default does not usually have this installed).

They also changed some Registry policies and this is why the old Registry tweaks you presumably were using no longer work.

I'm currently working on a way around this but thus far in terms of a Windows 10 Home edition I've not yet worked out a solution. I've not given up though, and should I figure out a way I'll let you know.

In the meanwhile, for a Windows 10 Home user, the lock screen you see should you press Winkey + L can be disabled very easily by renaming the SystemApps folder that contains the executable LockApp which Windows needs for this to function. Simply:
  • Open your File Explorer
  • Navigate to C:\Windows\SystemApps
  • Inside the SystemApps folder you will see this folder: Microsoft.LockApp_cw5n1h2txyewy
  • Right-click on Microsoft.LockApp_cw5n1h2txyewy and select Rename

    Simply add an exclamation mark before Microsoft like so:

    !Microsoft.LockApp_cw5n1h2txyewy


    After doing this when you press Winkey + L to lock you will go straight to the sign in page because Windows now cannot locate the LockApp.exe it needs for lock screen to function.

    Unfortunately though, it appears the lock screen you see when you first boot to login page is contained within a Windows Shell file. That's the bit I am working on to find a work-around.

For those using Windows 10 Professional, as I said, Microsoft removed their Group Policy option for disabling the Lock Screen. However, they forgot about the Local Security Policy (secpol.msc). They may change that too though as it seems they are determined to prevent this option. In the meanwhile though you can create a rule to completely disable the lock screen including on Startup by doing the following:

Note: You need to be logged in as User with Administrative privileges or as Built-in Administrator
  • In your Search box type Local Security Policy then press Enter key

    Alternatively, right-click
    on Start, select Run, and in Run dialog type secpol.msc then click OK
  • When the Local Security Policy window opens, in the left pane click and expand Software Restriction Policies then click on the subfolder Additional Rules

    Note: If for some reason the Additional Rules folder is not present, simply go to top toolbar then click on Actions and select New Software Restriction Policies then create the folder.

  • With the Additional Rules folder selected, next right-click inside the right pane and select New Path Rule
  • Under the Path simply Copy & Paste the following:

    C:\Windows\SystemApps\Microsoft.LockApp_cw5n1h2txyewy

    Note: If for some reason you've installed Windows on a different partition replace C: with the correct drive letter

  • Next set the Security Level to be Disallowed then click OK

That is all you need to do if you currently have Windows 10 Professional with the Anniversary Update installed. Unfortunately, Windows 10 Home Users do not have the Local Security Policy installed on their OS, so this work-around is no good to them. Hence, I'm seeing what other options there may be.

Will report back if I figure something out.

Regards,

Regedit32
 
Joined
Jul 26, 2015
Messages
56
Reaction score
6
Thankyou sooo much Regedit, you are so cool. And thanks for the very quick reply. I will await any other info you may supply when, as you say "see what other options there may be." Take care and God bless.
 
Ad

Advertisements

Joined
Feb 10, 2017
Messages
1
Reaction score
0
When I start up my lap top after the Anniversary Update it has once again the lock screen. It has that picture of the sea and rocks etc. All I need to do is click it and it disappears .. but I don't want the nuisance lock screen. I don't have a touch screen, I still use my mouse and pad. This lock screen is just another click I have to do to get started. Can any one help me on how to disable the lock screen.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top