Icons Change Size


Joined
Aug 28, 2018
Messages
12
Reaction score
0
I have had this problem for a while now. Some of my desktop icons change size?? I prefer my icons large but some seem to revert back to small. If I change them all to small view they will stay small but not if I want the large. It seems to be the URL shortcuts where I have made my own icons. I have attached a couple of screenshots to show what I mean. Hope someone can help. Its so frustrating.

John
 

Attachments

  • Screenshot (25).jpg
    Screenshot (25).jpg
    19.9 KB · Views: 157
  • Screenshot (24).jpg
    Screenshot (24).jpg
    19.4 KB · Views: 158
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,135
Any chance you are scrolling your mouse on the Desktop?

If you press & hold down the Ctrl key, and at same time with your mouse Scroll up the icons will increase in size, or Scroll down the icons will reduce in size. When you have a size you like, simply release the Ctrl key, then press F5 key to refresh Desktop.

The size you selected ought to remain stable.
 
Joined
Aug 28, 2018
Messages
12
Reaction score
0
They don't all reduce in size though. Just a few of them. I'm sure I have tried this before but will try it again.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,135
If it's only occurring with some of the icons ( the one's you created, when making a shortcut ), then perhaps the problem is you have already maxed out your Icon Cache itself, or it has become corrupted at some point.

In Windows 10 the default size for the IconCache.db file is 500 kb, but you can modify the Windows Registry to allow it to be a lot bigger.

If you make it bigger, it may resolve your current issue, plus you'll find when exploring folders with lots of images, they will likely load a lot faster too.

If you want to check its current size, do the following:
  • Open File Explorer, then in the address bar of File Explorer type the following: %localappdata%
  • Now in the top ribbon of File Explorer, click view then check the box next to Hidden items

    You should now see this listed:

    1574291746420.png


    In your case, you might note its a lot bigger in size than mine. If you have reached that 500 KB limit or are close to it, then you can modify the Registry to allow for it to be a lot bigger, thus reducing the likelihood of custom icons displaying wrongly. To do this, do the following:

  • Type cmd into your Cortana search field, then press Ctrl + Shift + Enter keys together.
  • When the User Account Control prompts you, click Yes to all an elevated commnd prompt to open.
  • At the elevated command prompt, type one of the commands below that meets your needs:


    To increase the IconCache size to 4 MB use this command:
    Code:
    reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer /v "Max Cached Icons" /t REG_SZ /d "4096" /f

    Press Enter key to execute command.


    To increase the IconCache size to 8 MB use this command:
    Code:
    reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer /v "Max Cached Icons" /t REG_SZ /d "8192" /f

    Press Enter key to execute command.


  • When done, type exit then press Enter to close the elevated command prompt.

    Note: To reverse this change, and thus reset the Icon Cache size back to the default 500 KB, simply enter the following command into an elevated command prompt:

    Code:
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer /v "Max Cached Icons" /f

Regards,

Regedit32
 
Joined
Aug 28, 2018
Messages
12
Reaction score
0
Thank you for that. I have a problem where after inputting this line it says "error access is denied". The IconCache size is at 119K

This is what I entered:

reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer /v "Max Cached Icons" /t REG_SZ /d "8192" /f


John
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,135
Type cmd into the Cortana search field.

In the search results right-click on Command Prompt and select run as administator
 
Joined
Aug 28, 2018
Messages
12
Reaction score
0
Thanks for that ... so helpful. I have done that now. I will see how it performs over the next few days and let you know. Thanks both again.

Kindest regards

John
 
Joined
Aug 28, 2018
Messages
12
Reaction score
0
Update:

My desktop icons seem to be behaving themselves up to now. All staying put and the right size
Thank you for your help. I was pulling my hair out with this one!

John
 
Ad

Advertisements

Joined
Oct 12, 2017
Messages
13
Reaction score
0
LOOK at the image i posted it might help (john in ireland)
 

Attachments

  • Screenshot_3.png
    Screenshot_3.png
    15.4 KB · Views: 155
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top