Left wireless mouse button click not working at all


Joined
Jan 6, 2018
Messages
1
Reaction score
0
Howdy, and before I get singed for not searching and reviewing posts please know that I have. Over the past couple of months I have tried every PowerShell script / scannow, driver update, reviewed control panel settings, installed and ran MANY antivirus programs, replaced batteries, left batteries out for an evening, tried multiple wireless mouses, and yes... even allowed a full MS software upgrade. Still same outcome.

So what has happened is I hadn't used my personal laptop for a couple of months and decided to break it out to backup my cell. Plug wireless mouse #1 in and boot... no left mouse click at all. Being a hardware and software guy from back to the '70's I took it apart and cleaned the contacts and validated continuity. Functions fine. Oh yes, and this is a Logitech M-RAA93. Try it on another computer... works just fine.

So to continue with troubleshooting tried a Microsoft MSK-1056 with identical results. NOTE: And yes, MANY cold and warm reboots in-between.

On to plan 'C'. A Keyspan RF Remote presentation device. It doesn't work just like the other mouses.

Last ditch (with dread, but need to troubleshoot), a wired mouse. Badabing... no problems other than I can't use that for my presentations.

Conclusion is that M$ pushed some update that has affected how wireless mouses interface with Windows 10. I can draw no other conclusion.

I will be sharing this identical post everywhere I see fit until I (hopefully) find a solution. At that point I will share the finding.

Thank you for assistance in advance, Matt

P.S. All of the aforementioned wireless devices work on other systems.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top