Security Certificate Alert Sometimes Pops Up Even When Website Is Safe


Joined
Jul 18, 2016
Messages
145
Reaction score
17
Every now and again I get a Security Certificate Alert window pop-up even when there is nothing wrong with the website I am on or other trust issues.

Can anybody tell me how I can stop these alerts from popping up unnecessarily? The security alert reads as below:
------------------
Security Alert

autodiscover.live.co.uk

information you exchange with this site cannot be viewed or changed by others. However, there is a problem with the site's security certificate.

X The security certificate was issued by a company you have not chosen to trust. View the
certificate to determine whether you want to trust the certifying authority.

X The security certificate has expired or is not yet valued.

X The name on the security certificate is invalid or does not match the name of the site.

Do you want to proceed?

Yes; No; View Certificate;

------------------

Thanks

HB
 
Last edited:
Ad

Advertisements

Joined
Feb 18, 2016
Messages
2,826
Reaction score
622
What browser are you using. Since yesterday I'm having a similar problem with a redirect.
Series of events: Yesterday I happened to open Edge to see if there were (none) any improvements.
When Edge opened Malwarebytes immediately flagged an attempted outgoing redirect to "Venturead.com" as a malicious website. Exited from Edge and ran Malwarebytes, Ccleaner and MRT. 0 malware reported. Today when I open some, (not all) websites with my regular browser Fire
Fox, I get the same warning from Malwarebytes, suspicious outgoing (venturead.com) blocked. This site is one of the sites were I occasionally see the warning.
 
Last edited:
Joined
Jul 18, 2016
Messages
145
Reaction score
17
Hi Norton,

I still use Internet Explorer 11. This notice seems to pop up now and again whatever website I am on, even websites I’ve used for years and that I know are safe.

I too have used Malwarebytes, HitmanPro and a series of other anti-malware products and all of them are coming up showing there are no infections.

I wish I Knew how to stop these blasted windows coming up without good reason.

Is there a setting somewhere in Windows to sort this?

Any ideas, anybody?

HB
 
Joined
Feb 18, 2016
Messages
2,826
Reaction score
622
You may want to check if IE 11 has a certificate manager in Settings>Privacy & Security.
 
Joined
Jul 18, 2016
Messages
145
Reaction score
17
You may want to check if IE 11 has a certificate manager in Settings>Privacy & Security.
Are you talking about the settings in Windows 10 itself? I've looked there and there is a 'Privacy' setting and an 'Update & Security' setting but not a 'Privacy & Security' setting. Am I looking in the right place?

Can you be a bit more specific to where I should be looking?

Thanks

HB
 
Joined
Feb 18, 2016
Messages
2,826
Reaction score
622
Last edited:
Ad

Advertisements

Joined
Jul 18, 2016
Messages
145
Reaction score
17
Okay, on the Privacy tab in Internet Options, there are a whole host of options including 'Sites,' 'Advanced,' 'Clear Sites' & 'Settings.'

I'll be on my laptop tomorrow so I can post screenshots to show you inside if that helps. Yes, I've seen the link before.

HB
 
Ad

Advertisements

Joined
Jul 18, 2016
Messages
145
Reaction score
17
On the Privacy tab in Internet Options, this is what show.
1. Privacy.jpg

On the 'Sites' Button, this is what is shown:
2. Sites.jpg

On the 'Advanced' Button, this is what is shown:
3. Advanced.jpg

On the 'Settings' Button, this is what is shown:
4. Settings.jpg

Is there anywhere on any of those settings that I need to tweak to stop the security alerts popping up?

Thanks

HB
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top