Some internet content not showing/working (Pictures and links)

SOLVED Discussion in 'Windows 10 Support' started by theVenerable, Jul 16, 2017.

  1. theVenerable

    theVenerable

    Joined:
    Aug 23, 2015
    Messages:
    22
    Likes Received:
    1
    Hi I'm Running Windows 10, with no other firewall or antivirus downloaded.
    Sometimes I cannot click pictures or links in my browser - nothing happens.

    I do have an ad blocker in my browser, but I also get the same problem when running the gaming platform Steam - I cannot subscribe to content or open some menus.
    Something is blocking my access, and it is on this computer only.
    My other windows 10 computer, which runs off of the same internet provider here, does not have a problem when browsing Steam or the internet.

    Please advise?

    Thanks
     
    theVenerable, Jul 16, 2017
    #1
    1. Advertisements

  2. theVenerable

    Wolfie

    Joined:
    Apr 22, 2017
    Messages:
    1,979
    Likes Received:
    210
    Hi theVenerable,

    what browser are you using and if you have several, does it do the same with all of them?. ;);)
     
    Wolfie, Jul 16, 2017
    #2
    1. Advertisements

  3. theVenerable

    theVenerable

    Joined:
    Aug 23, 2015
    Messages:
    22
    Likes Received:
    1
    Hello Wolfie

    Thanks for the reply
    If I open steam browser version ( I use Chrome and Explorer) I have some trouble with pictures not loading.
    And my actual Steam installation is not connected to any browser, but I can't access links and 'subscribe' buttons wont work etc.
    Yet, it all works fine on my other computer
     
    theVenerable, Jul 16, 2017
    #3
  4. theVenerable

    Wolfie

    Joined:
    Apr 22, 2017
    Messages:
    1,979
    Likes Received:
    210
    Hi theVenerable,

    if it is "Steam" specific, I would visit their forum as you will most likely find an answer there?:

    http://steamcommunity.com/discussions/

    If your browser is blocking things, have you looked at the settings of the browser and as to whether or not you have "Allow images" and/or "Block ads" etc active?. :)
     
    Wolfie, Jul 17, 2017
    #4
  5. theVenerable

    theVenerable

    Joined:
    Aug 23, 2015
    Messages:
    22
    Likes Received:
    1
    I didn't find and answer, but everything started working again luckily :p
    Thanks for the input
     
    theVenerable, Aug 6, 2017
    #5
    Wolfie likes this.
  6. theVenerable

    Wolfie

    Joined:
    Apr 22, 2017
    Messages:
    1,979
    Likes Received:
    210
    Excellent, please mark the thread as solved so it helps others!. :)
     
    Wolfie, Aug 7, 2017
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.