Some internet content not showing/working (Pictures and links)

SOLVED Discussion in 'Windows 10 Support' started by theVenerable, Jul 16, 2017.

  1. theVenerable

    theVenerable

    Joined:
    Aug 23, 2015
    Messages:
    22
    Likes Received:
    1
    Hi I'm Running Windows 10, with no other firewall or antivirus downloaded.
    Sometimes I cannot click pictures or links in my browser - nothing happens.

    I do have an ad blocker in my browser, but I also get the same problem when running the gaming platform Steam - I cannot subscribe to content or open some menus.
    Something is blocking my access, and it is on this computer only.
    My other windows 10 computer, which runs off of the same internet provider here, does not have a problem when browsing Steam or the internet.

    Please advise?

    Thanks
     
    theVenerable, Jul 16, 2017
    #1
    1. Advertisements

  2. theVenerable

    Wolfie

    Joined:
    Apr 22, 2017
    Messages:
    900
    Likes Received:
    115
    Hi theVenerable,

    what browser are you using and if you have several, does it do the same with all of them?. ;);)
     
    Wolfie, Jul 16, 2017
    #2
    1. Advertisements

  3. theVenerable

    theVenerable

    Joined:
    Aug 23, 2015
    Messages:
    22
    Likes Received:
    1
    Hello Wolfie

    Thanks for the reply
    If I open steam browser version ( I use Chrome and Explorer) I have some trouble with pictures not loading.
    And my actual Steam installation is not connected to any browser, but I can't access links and 'subscribe' buttons wont work etc.
    Yet, it all works fine on my other computer
     
    theVenerable, Jul 16, 2017
    #3
  4. theVenerable

    Wolfie

    Joined:
    Apr 22, 2017
    Messages:
    900
    Likes Received:
    115
    Hi theVenerable,

    if it is "Steam" specific, I would visit their forum as you will most likely find an answer there?:

    http://steamcommunity.com/discussions/

    If your browser is blocking things, have you looked at the settings of the browser and as to whether or not you have "Allow images" and/or "Block ads" etc active?. :)
     
    Wolfie, Jul 17, 2017
    #4
  5. theVenerable

    theVenerable

    Joined:
    Aug 23, 2015
    Messages:
    22
    Likes Received:
    1
    I didn't find and answer, but everything started working again luckily :p
    Thanks for the input
     
    theVenerable, Aug 6, 2017
    #5
    Wolfie likes this.
  6. theVenerable

    Wolfie

    Joined:
    Apr 22, 2017
    Messages:
    900
    Likes Received:
    115
    Excellent, please mark the thread as solved so it helps others!. :)
     
    Wolfie, Aug 7, 2017
    #6
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Wm. Larry Powell

    SOLVED Disable popup "Only secure content is displayed"

    Wm. Larry Powell, Dec 2, 2015, in forum: Windows 10 Support
    Replies:
    14
    Views:
    2,067
    Wm. Larry Powell
    Dec 14, 2015
  2. Mark Vincent

    Folder Content Issues

    Mark Vincent, Dec 20, 2015, in forum: Windows 10 Support
    Replies:
    0
    Views:
    340
    Mark Vincent
    Dec 20, 2015
  3. expat_us

    Yahoo - links to my internet searches

    expat_us, Dec 24, 2015, in forum: Software
    Replies:
    0
    Views:
    451
    expat_us
    Dec 24, 2015
  4. DaveMc

    Windows 10 not saving desktop links and bookmarks

    DaveMc, Mar 27, 2016, in forum: Windows 10 Support
    Replies:
    1
    Views:
    547
    Regedit32
    Mar 27, 2016
  5. Elle V
    Replies:
    10
    Views:
    416
    joetech1
    Apr 22, 2016
  6. Patrick Jørgensen

    My Pictures content missing after update

    Patrick Jørgensen, Oct 5, 2016, in forum: General Discussion
    Replies:
    9
    Views:
    544
    Patrick Jørgensen
    Oct 9, 2016
  7. COAT
    Replies:
    0
    Views:
    213
Loading...