USB mass storage device


Joined
Mar 15, 2020
Messages
2
Reaction score
0
Is anybody out there you can help me weight problem regarding code 10 under device manager in USB storage device.
Basically what it is when I plug in my external Western Digital hard drive the window is not recognizing.
In when I go to device manager I see yellow !
I tried already so many different things, searching online and so far no help.
Please I'm so desperate to fix this issue because I need that hard drive to be open.
Anybody's help very appreciate
thank you very much
Daniel
 
Ad

Advertisements

Joined
Oct 1, 2014
Messages
2,334
Reaction score
358
The model number of the drive may help some folks recognize a problem.. USB 2.0 or 3.0/.1

Do other USB devices seem to work normally?

Are you plugging it in after the system is running and you have tried changing USB ports?

Do you show any yellow markers or unknown on any other devices?
 
Joined
Mar 15, 2020
Messages
2
Reaction score
0
My drive is WD My passport and until recently it worked without problems.
When plugin any other drive has no problem.
There is no yellow marers anywhere but just when I put that WD drive on.
 
Joined
Oct 1, 2014
Messages
2,334
Reaction score
358
I have a 2 TB, fairly new WD Elements external drive and it seems to be OK. I remember some of the external drives some time ago were having problems and some of the WD models were mentioned.

Three drivers seem to be showing, but this might depend on your system.
disk.sys
EhStorClass.sys
partmgr.sys

Are you switching the drive between systems?

If you look in the Device Manager and allow it to show hidden devices, you might see some greyed out versions of the drive. You may be able to uninstall all the entries for the device.

You might also look at the Events tab on the Drive's Properties to see if you can tell if a driver might be failing. Make sure and check the USB drivers also..
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
5,927
Reaction score
1,223
What do you see if you open the Disk management? (If anything!)
The yellow triangle doesn't give much away, but usually means there is a conflict or something out of place - not necessarily a failure.
I would go down in the device manager ( Universal Serial bus controllers)and select your usb devices one by one and attempt an update from the internet. It might hit the right one and you are back in business.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top