Win 10 unable to map router usb HDDs


Joined
Feb 24, 2020
Messages
4
Reaction score
2
I have had to reinstall Win10 as a result of on board HDD issues. I am running version 1909 build 18393.657 on an Asus M5A78L-M PLUS USB3 mother board. The on board network controller is enabled in the bios. A lan cable connects to a TP-Link Archer C9 router with 2 attached USB HDDs. These are accessible from other devices so I think the router setup is OK. Internet access works.
I must be missing something simple, I cannot map these drives. I was able to do so in the previous installation.
Any help will be much appreciated.
 

Attachments

Ad

Advertisements

Joined
Jun 9, 2017
Messages
602
Reaction score
127
Since the USB drives are still working for your other computer, I think you might check Services.msc look for
Function Discovery Provider Host
Function Discovery Resource Publication

Type services.msc
Right Click and select to run as Admin
Ensure they are both set to start Auto
Also if they are running currently Restart them then check again for these USB Drives
 
Ad

Advertisements

Joined
Feb 24, 2020
Messages
4
Reaction score
2
Thanks for your reply ClintIgm. I followed the steps, both set to auto and restarted. Still unable to map the drives, same error 0x80070043.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top