Why does my laptop randomly go to sleep with Windows 10 Install


Joined
May 18, 2016
Messages
1
Reaction score
0
It is running on AC power, not battery, I have checked in Power Settings and it is set to 30 mins, but if computer is untouched for 2 mins it goes to sleep and I have to put my password in to continue. Driving me crazy.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
2,937
Reaction score
910
Hi Donnals,

There are a couple of possibilities that come to mind:
  • Restore Default Power Plan
  • System Unattended Sleep Timeout

Restore Default Power Plan

Occasionally things get a little confused and settings as a result are ignored. In that scenario you can:
  • Click Start > Settings > System > In the left pane click Power & sleep
  • Next in the main window (right pane) click the Hyperlinked Additional power settings
  • The Power Options window opens: Click the hyperlinked Change plan settings
  • Click the hyperlinked Restore default settings for this plan
  • A Power Options alert will pop up: Click YES

If that does not resolve your troubles then the next step is worth trying, albeit a little more complicated.


System Unattended Sleep Timeout


This setting by default is hidden from the context menu of the Panel we need to access to adjust it's settings.

As a result we need to first modify the Windows Registry to make sure you will see this setting when directed to its location. To avoid opening the Windows Registry itself, where in this case it would be very easy to select the wrong key to modify I'll give you two commands to enter via an Elevated command prompt.

Afterwards, I'll point you to the context menu where you will now be able to view this setting and adjust as necessary.
  • Right-click on Start then left-click on Command Prompt (Admin)

    This will open an elevated command prompt to C:\WINDOWS\System32>
  • At this prompt type or copy & paste the following command, then press Enter key to execute

    Code:
    REG DELETE HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0 /v Attributes
    After pressing Enter this command will delete the REG_DWORD Attributes from the key. This needs to be done so we can add the same value back with a modified state.

  • Next at the command prompt type or copy & paste the following command, then press Enter key

    Code:
    REG ADD HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0 /v Attributes /t REG_DWORD /d 00000002
    After press Enter this command replaces the REG_DWORD Attributes just removed with a modified Data Value of 00000002. This will allow you to view the System Unattended Sleep Timeout option in the context menu we are about to go to.

  • Type Exit at the command prompt then press Enter key to close the window
  • Next click Start > Settings > System > In the left pane click Power & sleep
  • Next in the main window (right pane) click the Hyperlinked Additional power settings
  • The Power Options window opens: Click the hyperlinked Change plan settings
  • The Edit Plan Settings window opens. Click the hyperlinked Change advanced power settings
  • This pops up the Power Options window Advanced settings tab. Here expand +Sleep like so:
— Sleep
+ Sleep after
— System unattended sleep timeout

Setting: 2 Minutes
  • Click that 2 Minutes to adjust to a time delay you want
  • Click Apply
  • Click OK
Regards,

Regedit32
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
4,299
Reaction score
842
open the "Settings" - Accounts. - Sign in options.

Under "require sign in". Select "Never."


,
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top