SOLVED Win 10 Pro changes Excel Date Format


Joined
Jul 30, 2015
Messages
17
Reaction score
1
I have just upgraded from Win 7 Pro 64bit to Win Pro 64bit. I notice the Date Format in my Excel files have been changed.
When I go into CP/Region I cannot find a Format available to display example 6/11/2016 but 6-11-2016 is available.
Someone has forgotten to add the British Date Format and we are left with US Date Format, but only for this particular d/mm/yyyy Format. I have two machines that have this undesirable problem.
This problem does not apply to Win 10 Home OEM (HP)
How does one overcome this nasty in Win 10 Pro.
The d-mm-yyyy Date Format is no good for Australia.
I have tried Language set to English (Australia) and English (United Kingdom) with no difference.
Help Please.
 
Ad

Advertisements

Joined
Feb 18, 2016
Messages
2,826
Reaction score
622
Owen it's related to Britex :D
Try this:
Windows allows users to change the date and time format Go to Settings > Time and Language > Change date and time formats. I'm not sure, but, you may have to change the language pack to English (United Kingdom)
 
Joined
Jul 30, 2015
Messages
17
Reaction score
1
I am using English (United Kingdom) and I have used my Native English (Australia) and neither provide the Date Format as dd/mm/yyyy in the Date Format Dropdown, but do show this particular style of Format as dd-mm-yyyy and all other Styles (US) are provided as mm/dd/yyyy, etc. In Win 10 Pro the British common style dd/mm/yyyy has been left out of the Drop down, thereby forcing one to use dd-mm-yyyy, but that is not the case for Win 10 Home, which does have it. If you are using Win 10 Pro, have a look yourself.
This seems to be an oversight by MS, but how do we get them to correct it. Their Support for 10 is hopeless on Answer Desk, my 11 year old Grandson could do better.
 
Joined
Feb 18, 2016
Messages
2,826
Reaction score
622
Yes I did take a look in XL it's as you say dd-mm-yyyy.
You say the dd-mm-yyyy. can't be used in Australia. Bugger! Really, there is no hard fixed rule, it depends what country you are in as to the context used. Born in the UK I prefer dd/mm/yy that was the way I was taught in school. In reality I find date formats are confusing.
If I was to read an important document dated 6/10/2015 is that 6th of November 2015 or June 10 2015?
Honestly, I prefer the ISO standard (yyyy/mm/dd 2015-10-06. The ISO standard can only be interpreted one way no matter what country you are in. I think the ISO standard will be the norm very soon and I'm surprised MS didn't use the ISO date format in Windows 10. I bet you prefer driving on the left too. :D

Cheers! Mate
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,127
Have you tried adding a Date setting?
  • Right-click on Start
  • Left-click on Control Panel
  • If not all ready; set to view by Category
  • Under Clock, Language, and Region click on Change date, time, or number formats
  • When the Region dialog opens click on Additional settings button
  • When Customize Format dialog opens click on Date tab
  • In the Short date box highlight the current content and type over with d/MM/yyyy
  • Click Apply, then click OK to close dialog. Now back in the Region dialog click OK

    Now try opening Excel to see if your new short date format works or can be selected as an option.
 
Joined
Jul 30, 2015
Messages
17
Reaction score
1
I did not say that dd-mm-yyy cannot be used in Australia - It Can, but I, like many others, have been used to using the "/" Slash Format for my 82 years and why should we change now because MS think they know better. All opf the work I have created over the years ( Excel and Database ) amounting to a rather huge volume, has converted to a Format I do not wish to use.
I have tested on both British and Australian Language Versions and the Pro version dropdown for Date Format are the same. I cannot use the British version as Keyboards are different - @ key Australian is " Key on British. Emails do not work with " Character instead of @.
Then also ask yourself why MS did it correctly in the Win 10 Home version, which is generally not used for high end business activities.
They do not seem to have a hard and fast rule - In the Pro version of 10, you will notice that the "/" Date Format has been provided for all others except, dd/mm/yyyy.
This has to be a simple Oversight on the part of Programmers or a straight out Undetected Error of Typing.
But the serious question is;;;;;; How and When do we get this corrected as one can no longer Email Tech Support with the Story, all you can do is Chat with a Totally Unexperienced kid on the Answer Desk.
Thank God we did not have to Pay for this Upgrade - What what can you expect for Free these days.
Yes, I feel more secure on the Left side of the road, although in these times of Drug and Alcohol use on the roads, one wonders where to drive, to miss these Demons of the Road.
 
Ad

Advertisements

Joined
Feb 18, 2016
Messages
2,826
Reaction score
622
Whoa! Owen. It's not always Microsoft that's to blame. Example; Manufactures of Laptops sold here in Canada are mandated by the Federal Government that all Laptops sold in Canada must have both US and French characters.
I expect you have the same situation re-keyboards, but you can't blame Microsoft. They actually do a great job with programming some 30 languages, UTC time zones... MS have come a long way since Windows 3.0.
In the PC world things can't remain as is forever or we would still be using a Commodore 64.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,127
The point was to modify the settings by adding that Short Date - not to tell you what you can or cannot do.

Another way you could modify this is via the Registry. First though you might want to check what the current value is by opening a command prompt and entering the following command:
  • Code:
    reg query "HKEY_CURRENT_USER\Control Panel\International" /v sShortDate
    Normally this would return: sShortDate REG_SZ d/MM/yyyy

    Does yours? If not change it to that.
 
Joined
Jul 30, 2015
Messages
17
Reaction score
1
I went back to what Regedit32 has shown in the earlier Post - Re Read it and applied it and Bingo, it worked - Both my Excel Files have returned to my Required Format and my Date and Time on the Task Bar are now correct. I did not understand what was involved with Additional Formats - I was expecting a list of Additional Formats, not realizing that I could simply type over the selected one and it would be accepted.
Thank you to all Contibuto
Whoa! Owen. It's not always Microsoft that's to blame. Example; Manufactures of Laptops sold here in Canada are mandated by the Federal Government that all Laptops sold in Canada must have both US and French characters.
I expect you have the same situation re-keyboards, but you can't blame Microsoft. They actually do a great job with programming some 30 languages, UTC time zones... MS have come a long way since Windows 3.0.
In the PC world things can't remain as is forever or we would still be using a Commodore 64.
Sorry, MS, I was wrong in this case - The Solution was there all the time but there was nothing to tell anyone how to use it - Great with Hindsight. But if they could provide a Date Format Dropdown for Win 10 Home, why not do the same for Win 10 Pro - beggars belief. I cannot find a Button to make this SOLVED.
 
Ad

Advertisements

Joined
Jun 12, 2020
Messages
1
Reaction score
0
Simple way is : click on Start > Search > Control Panel> Region dialog> Change anything if you need . then OK

---

Best Regards!

Hannah J. Parrish
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top