Windows 10 PCs get no home WiFi when joined to office domain.

Joined
Feb 12, 2018
Messages
1
Reaction score
0
We have Windows 10 laptops and Surfaces that experience this issue. When the laptop is in a workgroup, they appear to not experience the issue. The issue also does not always occur right away. Once the Windows 10 PC is joined to the domain, it works fine in the office. When they take it out of the office, it won’t connect to WiFi.


We have run the following commands as suggested in the forums, but they have not solved the issue.


netsh winsock reset catalog

netsh int ipv4 reset reset.log

netsh int tcp set heuristics disabled

netsh int tcp set global autotuninglevel=disabled

netsh int tcp set global rss=enabled

sc config NlaSvc start= delayed-auto

ipconfig /release

ipconfig /renew

ipconfig /flushdns

ipconfig /registerdns


We have tried removing the WiFi hardware from the Device Manager and rebooting.

We have tried updating the WiFi drivers.

We have tried running a ‘Windows Refresh’, and a ‘sfc /scannow’.


When we run the troubleshooting, we get the following message…

‘Windows does not have a valid IP configuration and it was not fixed’


There are no WiFi policies on the domain. There are no encryption settings in Group Policy.


From our testing the PCs do not obtain an IP address and the networking shows ‘No Internet, Secured’.


We have worked with both Sonicwall and Microsoft and they have been able to confirm that the DORA request is not being handled correctly by the Windows 10 PCs.


The only fix we have so far is a complete reload of the PCs, but this is not a workable solution.
 
A

Advertising

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
2,937
Reaction score
908
Hi Isquez,

Welcome to the Forum.

It seems you have done about every test that first comes to mind, and with Microsoft involved too!

The only thing I can think of is to create a new Group Policy directly via the Registry which will force a Automatic Connection to WiFi Network even if a LAN is connected to computer.

To do this:
  • Press your Windows key + S to give focus to the search field
  • In the search field type Command
  • In the search results right-click on Command Prompt and select Run as administrator
  • Click Yes when the User Account Control prompts you
  • In the Administrator: Command Prompt console type or copy & paste the following:
Code:
REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WcmSvc\GroupPolicy" /v fMinimizeConnections /t REG_DWORD /d 1 /f
Press Enter key to execute

Type exit and press Enter key to close console.

Restart computer for policy to take affect.​


There is no guarantee this will resolve things, but it'd be worth testing it out to see if it makes a difference.

You could check with Microsoft first if you are not sure.

If it makes no difference, then:

Code:
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WcmSvc\GroupPolicy" /v fMinimizeConnections /f
Press Enter key to execute, will delete the policy, or:

Code:
REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WcmSvc\GroupPolicy" /v fMinimizeConnections /t REG_DWORD /d 0 /f
Press Enter key will disable the policy.

In both cases a restart of computer will be needed for changes to take affect.
 
A

Advertising

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top