SOLVED After downloading major updates, Documents Folder under My PC is only showing OneDrive folders.


Joined
Jul 18, 2016
Messages
170
Reaction score
17
I have just updated Windows 10 with its recent, major Windows updates (the ones where the computer shuts down and restarts several times). The updates now show Windows Defender with a completely new interface.

Since doing these updates I have noticed looking at Windows Explorer on the left-hand side column, OneDrive shows in its normal place at the top with its usual green tick. Then under that, ‘This PC’ shows with its usual libraries: Desktop, Documents, Downloads etc. except with the ‘Documents’ folder, this is also showing with a green tick. When clicking open this folder, instead of showing where all my documents are, this is showing exactly the same folders that are in OneDrive.

Before I updated, the documents folder showed normally without the green tick and with all my documents inside. To get to my documents now, I have to click on, Storage Drive D which is further down the column below the other libraries.

Can anybody tell me why this has happened?

Can anybody tell me how I can put my documents so they are where they should be under This PC in the libraries as they were before the updates?

Can anybody tell me if I can get rid of the documents folder with the green tick without causing any problems?

Thanks

HB
 
Last edited:
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
Are you able to show a screen shot of your File Explorer when OneDrive is selected?

In Creator, OneDrive has 4 default folders, but if a new folder was created and your Documents were move to the new folder, then you can move them back easily enough, by:
  • right-clicking the new folder in OneDrive directory and selecting Properties
  • Select Location tab
  • Click the Move button
  • Navigate to This PC > C : > Users > your Username then click Select folder
  • Now in the field above the move button add \Documents [ e.g. C:\Users\Regedt32\Documents ]
  • Click Apply, then when prompted click Yes and finally click OK
This creates a new Document folder for the User account and moves the docs back there.


If on the other hand, your User Account documents has been moved to OneDrive's default Document folder, that is a different issue and it a little trickier to resolve as when this is done you are warned doing so cannot be reversed.

That is not entirely accurate, but it is certainly more difficult to resolve.

If you are lucky, OneDrive is still present in your System Tray - in which case you can:
  • right-click and select Settings
  • Select Auto Save tab
  • Change the fields to THIS PC

Let us know how you go and whether the problem persists. Also, if you can post a screen shot of your File Explorer when OneDrive is open, that would help to see what is going on, should further advice be needed.
 
Joined
Jul 18, 2016
Messages
170
Reaction score
17
I haven't tried your advice yet but here is a screenshot of what should be my documents. You can see that the documents folder has a green tick on it and when opened, shows the exact folders that are shown in my OneDrive folder. Originally, before I updated Windows, the Documents Folder was shown where it is now but without the green tick and with my regular documents inside. To get to my documents now, I have to go to storage drive D further down the column as you can see. Does this give you a better picture of what I was trying to explain? Should I try your previous advice or can you see the problem now? Thanks. HB

OneDrive Documents.jpg
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
The green checks confirm syncing was completed successfully.

The good news is those are unique folders, meaning if you do not want to sync into OneDrive, you can move them back as I previously explained.


Regarding the Documents folder below This PC showing you what is in OneDrive instead of your User Account Documents folder. That is determined by a Registry value located here:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

My assumption is that has been modified when you set up OneDrive.

Try the following:
  • Press Windows key + R
  • In the Run dialog type regedit then click OK
  • Click Yes when the UAC prompt appears
  • In the Address bar of the Registry Editor window, type or copy & paste the following:
Code:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Press Enter key
  • Now take a look in the right pane. Do you see this?
img1.png



If you see that GUID value there pointing to %USERPROFIILE%\OneDrive\Documents then:​
  • Right-click on {F42EE2D3-909F-4907-8871-4C22FC0BF756} and select Delete
  • Press F5 key
  • Close the Registry Editor
  • Restart computer
Doing the above will reset the default status, and now the Documents folder below This PC should point to its usual location: %USERPROFILE%\Documents [ for example: C:\Users\Regedit32\Documents ]


:
 
Joined
Jul 18, 2016
Messages
170
Reaction score
17
I have attached my registry at the point where you have indicated. My libraries are set on my D drive, so was my original documents folder. Looking at the registry, can you tell me from that what I need to change and what to change them to so that my documents library are placed normally without the green tick with the other library folders?

My one drive folder, I use for certain folders so I do use this but separately to my folders library. Thanks
HB

Registry.jpg
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
img1.jpg


  1. This is the registry key I previously mentioned deleting. You can, if you prefer, double-left-click and modify by replacing the Data value with "%USERPROFILE%\IB Working Documents"
  2. This key is almost superfluous as C:\Users\Andy\OneDrive\IB Working Documents is the full path equivalent of %USERPROFILE%\OneDrive\IB Working Documents because %USERPROFILE% is a short way to say C:\Users\<Username of Current User> or C:\Users\Andy

    However,
    if your usual Username is not Andy but something else, then the 1 key mentioned is pointing to that Username and not Andy, so if that is the case, you can still modify this and make it "C:\Users\Andy\IB Working Documents"
  3. This can be modified to point to C:\Users\Andy\Pictures\Pictures\Camera ... where the ... is whatever the remainder of the path is that is not in view in your image

  4. This one can be modified to point to C:\Users\Andy\Pictures\Pictures

??? As this string exists, that made me wonder precisely which files did you actually want to appear in OneDrive. If you are wanting to keep the IB Working Documents in OneDrive, then you really only need to delete the first key which I numbered as 1. The other three keys (2, 3 & 4) could be left alone.
 
Ad

Advertisements

Joined
Jul 18, 2016
Messages
170
Reaction score
17
Thank you for your detailed explanation. Before I go plunging in can I just ask; after performing these procedures, will my OneDrive folder on the left hand navigation pane (the one showing the cloud icon with the green tick) be left? As I obviously want this folder and it already has the IB Documents folder within it.

I won't need the IB Documents folder which is the documents folder with a green tick on it as this is a duplicate to what is in my OneDrive folder. I would like the documents folder icon to be shown without the green tick with my regular documents in them below the downloads.

So if I follow your procedures that are numbered, will this achieve the outcome I want as explained above?

Thanks

HB
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
I'd do step 1 first and only this step, then check your results.

That step ought to reset your Documents folder under This PC back to a standard document folder that is not synced to OneDrive. It should not delete the content of the folder, just unbind it from OneDrive and allow it to be the Standard User's Document folder.

If you want to be extra sure; then before doing a change press Windows key + S and in search field, type create a restore point then press Enter key and create a restore point which will take a snap shot of the Registry before you modify it, so if you get a result you do not want, you can use System Restore to return back.
 
Joined
Jul 18, 2016
Messages
170
Reaction score
17
Okay, I decided to delete the value that you numbered 1 in the registry and after restarting the computer, the documents folder did show as normal without the green tick. That is good news.

However there are 2 points to add.

1. Inside that folder all I had was another folder named Visual Studio 2015, not my regular documents or anything else. In this case, could I just put back all my documents from my D drive into this folder and then it will be how it originally was?

2. As I said earlier, all of my libraries were originally all on the 'D' drive to save disk space. This new Documents folder is on the 'C' drive. Can you tell me how I can put this on the D drive so that it matches all the other libraries?

Thanks

HB
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
Yes, now that you have set it to be a Stand Users Document folder you ought to be able to move documents from other locations back to the folder.

You could right-click the Documents folder and select Properties then select the Location tab and type the location or using browse select the location on D drive where you'd like it to be, then click the Move button and finally click Apply then OK
 
Joined
Jul 18, 2016
Messages
170
Reaction score
17
Brilliant! Thanks for all your help in guiding me through the process. Everything is as it should be now.

HB
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
You're welcome Heathsideboy.

I'm glad you managed to get things setup the way you prefer.

Might be a good time to create a System Restore point, so if things go weird later you can use the Restore point to quickly return to how you like it.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
In your search box type create a restore point then press Enter key to open the dialog.

From there you just click the create button and name the restore point whatever you like.

Before clicking the button you can select drives to back up if you want.
 
Ad

Advertisements

Joined
Feb 7, 2018
Messages
1
Reaction score
0
Regedit32, appropriately enough, your regedit solution worked perfectly! Thanks so much; this had been driving me nuts for quite a while.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top