SOLVED Erratic boot


Joined
Aug 30, 2016
Messages
15
Reaction score
1
I have an external hard drive on which I keep many of my files. There's a shortcut to it on the desktop.

If it's plugged in before boot, the boot doesn't work'

I have to disconnect it and the PC boots ok.

What can cause this and how can I overcome it?
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,521
Reaction score
1,076
When you first turn on your computer, press the button it mentions on screen to go into your Bios Settings.

Once in the Bios settings, check your Boot order. It's possible the boot order is set to read from USB drives before it attempts to read your internal hard/ssd drive.

If that is the case, simply change the boot order, so it reads your internal hard/ssd drive first, then you should be able to leave the external drive plugged in without it preventing Windows from booting.
 
Joined
Oct 1, 2014
Messages
2,220
Reaction score
324
I had a Seagate external drive that did that for a while a few years ago. I don't think I changed anything but the drivers or OS was updated.

Do you have OEM software that runs on that drive or is it just storage?

I might look for firmware updates for the drive or Bios updates for your system. See if the OEM has any info on the situation.
 

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
12,554
Reaction score
2,028
I had a Seagate external drive that did that for a while a few years ago.
Same here.
Never did bother figuring it out, and....
although my memory is not all that good anymore, as I remember it was unique to a particular HP desktop computer.

I don't recall having the issue when it was attached to other computers.
 
Ad

Advertisements

Joined
Aug 30, 2016
Messages
15
Reaction score
1
When you first turn on your computer, press the button it mentions on screen to go into your Bios Settings.

Once in the Bios settings, check your Boot order. It's possible the boot order is set to read from USB drives before it attempts to read your internal hard/ssd drive.

If that is the case, simply change the boot order, so it reads your internal hard/ssd drive first, then you should be able to leave the external drive plugged in without it preventing Windows from booting.

Yes, it was the boot order; USB first. Changed it.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top