SOLVED Gain full control of my PC


Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello,

I'm trying to take full control of my PC without success.

Here is an example: I want to completely disable Quick Access and I followed the steps indicated there:

http://www.isumsoft.com/it/disable-quick-access-in-windows-10-file-explorer/

However, reaching the specific step where you can modify permissions, it is impossible to check any option since boxes are in grey as showed in pdf "Permission Entry" uploaded.

Then, I tried many, many things, changing type account, and so on... Nothing works.

Thank you for any kind of help.
 

Attachments

  • Permission Entry.pdf
    298.5 KB · Views: 299
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,130
Hi JZIZ,

Welcome to the forum.

It seems to me the issue you are experiencing is owing to two factors:
  • You've only just taken control as owner, so such controls cannot be reflected without a restart
  • Second, the Administrators is inheriting rules of System and TrustedInstaller

The logical thing to do in this instance would be to ignore the advice in article and rather than double-click the Administrators you just took ownership with, simply close out that window completely and instead back in the opening Permissions window ( the first one you saw when you started this process ), left click your Administrators there to select it, then in lower panel check mark Full Control there.

Once done if you then follow the steps back to where your window is greyed out, you ought to now see the appropriate boxes checked and you can apply this change, then reboot system.

Sample image

Untitled.png



Regards,

Regedit32
 
Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello Regedit32,

Thank you for your answer.

I did try what you propose - I've already tried it - and here is the result:

upload_2017-2-17_9-34-33.png


As you may notice, I checked the full control box but the "access is denied"

I would very much appreciate a hand on this. Thank you again for your time.

Regards,
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,130
OK then let's approach this task using a more powerful tool.
  • First, download SetACL: https://helgeklein.com/downloads/SetACL/current/SetACL (executable version).zip
  • Once downloaded extract the zipped folder. Inside you'll see a folder with same name. Open this to discover a 32 and 64-bit folder. Simply open the folder that matches your computers Architecture; which given its age ought to be a 64-bit Architecture. Inside the 64-bit folder copy the SetACL.exe and paste this inside your C:\Windows\System32 folder. If prompted click Continue button to give administrator permission for the copy.
  • Next do the first steps of your article again; i.e. open File Explorer, select folder options, select This PC, check the boxes and click OK.
  • Close File Explorer when done.
  • Now right-click on Windows flag and select Command Prompt (Admin)
  • When prompted by the User Account Control click Yes
  • Inside the Command Prompt: Administrator console type or copy & paste the following commands, pressing Enter key after each command to execute:

    Code:
    SetACL.exe -on "HKEY_CLASSES_ROOT\CLSID\{679f85cb-0220-4080-b29b-5540cc05aab6}\ShellFolder" -ot reg -actn setowner -ownr "n:Administrators"

    Press Enter key

    Code:
    SetACL.exe -on "HKEY_CLASSES_ROOT\CLSID\{679f85cb-0220-4080-b29b-5540cc05aab6}\ShellFolder" -ot reg -actn ace -ace "n:Administrators;p:full"

    Press Enter key

    Code:
    reg add "HKEY_CLASSES_ROOT\CLSID\{679f85cb-0220-4080-b29b-5540cc05aab6}\ShellFolder" /f /v Attributes /t reg_dword /d "0xa6000000"

    Press Enter key

    Close Command Prompt: Administrator console

    Restart computer

    Done!
Regards,

Regedit32
 
Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello,

OK great, I did it and it works. I can check the full control box and I made the change indicated in the article. Many thanks for this help.

But now, the article is wrong ! http://www.isumsoft.com/it/disable-quick-access-in-windows-10-file-explorer/

I changed the attributes value data from a0100000 to a0600000 as mentioned but this change didn't produce the expected effect: Quick Access is not disabled and always appears in the navigation pane of File Explorer.

I'm sorry to ask again for your help but if you have an idea of how to manage this, I'd appreciate a lot.

Thank you
 
Joined
Feb 16, 2017
Messages
14
Reaction score
1
Something more.

There is now a Quick access icon on the desktop that I cannot remove. Exactly what I don't want.



It's unbelievable, it's doing all the things I don't want.

Thank you for your help.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,130
Microsoft changed the way Quick Access content is stored in the Registry.

The article you are using is outdated.

Before attempting to provide a method around this can you clarify what precisely you are wanting to achieve. Do you simply not wish to see Quick Access in either the navigation pane (left side) or main window of File Explorer?

Or is it something else you want to achieve?

In the meanwhile, if you wish to restore things back to what they were prior to the modification of the Attributes value, and thus make Quick Access disappear from Desktop, then type or copy & paste the following into the Command Prompt: Administrator:
  • Right-click on Start and select Command Prompt (Admin)
  • When the User Account Control appears click Yes
  • At the prompt type or copy & paste the following:

    Code:
    reg add "HKEY_CLASSES_ROOT\CLSID\{679f85cb-0220-4080-b29b-5540cc05aab6}\ShellFolder" /f /v Attributes /t reg_dword /d "0xa1000000"

    Press Enter key to execute

    Close the Command Prompt

    Done!


Regards,

Regedit32
 
Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello Regedit32,

Once again thank you for your help.

I executed the command you recommend and it seems fine. No more Quick Access icon on the desktop.

What I want to achieve is to completely get rid off off Quick Access. I want it "deleted" from the navigation pane of File Explorer. I don't want to have access to "Quick Access" in any way possible.

I hope I've been crystal clear. If not, forgive me, English is not my native language.

Thank you both for your time and help. From your side, your pieces of advice and your explanations are very clear.

Regards,
 
Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello Regedit32,

I don't know if you read my last post. I really need your help on the above matter: permanently remove quick access from file explorer. I want this option to disappear from file explorer.

I told you I tried many options and nothing works. Quick access always appears in file explorer.

Thank you in advance for your help much appreciated.

Regards,
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,130
OK,

Sorry I needed to update my Windows 10 Home to test a few things.

To get rid of this Quick Access do the following:
  • Open File Explorer and in the top ribbon select View | Options
  • In the window that appears (1) select This PC, then (2) make sure both boxes in the Privacy panel are clear, then (3) click the Clear button, and finally (4) click Apply then (5) OK

    Sample image

    qa.png

  • After clicking OK above you'll be back in your File Explorer folder. In the Left-pane expand Quick Access then right-click on each item in the Quick Access directory and select Unpin from Quick Access

    Sample image

    qa2.png

  • Close File Explorer
  • Press Windows key and R key to open the Run dialog.
  • In the Run dialog type regedit then click OK
  • When the User Account Control alert appears click Yes
  • In the Registry Editor on the left pane expand the HKEY_CLASSES_ROOT to this location:
HKEY_CLASSES_ROOT
— CLSID
{679f85cb-0220-4080-b29b-5540cc05aab6}
  • Again, in the left pane, right-click on the sub-key {679f85cb-0220-4080-b29b-5540cc05aab6} and select Permissions

    Sample image

    qa3.png


    This will open the Permissions window. Click on the Advanced button.

    Sample image

    qa4.png


    That will open the Advanced Security Settings window and here you'll see the Owner up top. Click the Change next to the Owner name.

    Sample image


    qa5.png



    That will take you to the Select User or Group window. Type Administrators then click Check Names button. When the appropriate name appears click OK

    Sample image

    qa6.png


    After clicking OK you will be returned to the previous Advanced Security Settings window. Here you will now see your new Administrators name is the Owner. Just beneath this check the box then click Apply and then click OK

    Sample image


    qa7.png


    After clicking Apply then OK you will be returned to the Permissions window. Here left click your Administrators name you just chose to be owner to highlight it then below check the Full Control box in the Allow column and finally click Apply then OK

    Sample image


    qa8.png
  • Having clicked the Apply then OK you'll be back inside your Registry Editor window. At this point in the left pane expand the sub-key {679f85cb-0220-4080-b29b-5540cc05aab6}
  • Left-click on the sub-key ShellFolder to view its contents in the right pane.
  • In the right pane simply right-click on Attributes and select Modify. In the window that opens, replace the default Data value a0100000 with a0600000 then click OK

    Sample image

    qa9.png
  • Close your Registry Editor window and any other open programs,
  • Restart computer.
  • Done!

    The end result:

    qa10.png
  • Some notes
    • To reverse this either user a restore point or,
    • Open file explorer, select View tab, select Options and select Open File Explorer to: Quick Access.
    • Next open Registry Editor and modify the Attributes by changing Data value from 0a600000 back to 0a100000, then close Registry editor and any other open programs and restart your computer.
    • Also note, removing Quick Access disables your ability to drag and drop files/documents inside File Explorer, which in my opinion is a big negative for doing this at all.

Regards,

Regedit32
 
Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello Regedit32,

Thanks for coming back.

I did everything you recommend and it didn't work out:

upload_2017-2-21_19-46-32.png


Quick access still appears....

I really don't know what to do.

If you have another idea, you are more than welcome.

Thank you.

Regards,
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,130
Press Windows Key and S key together to give focus to Search box.

Type winver then press Enter

Post me a screen shot of window that appears so I can see what version of windows you are on.


Also, do you have a restore point you can use to go back to before you originally started on this project? It may help to use this and start over as you have been trying this for a few days now and there may be something you did earlier that is preventing the above instructions achieving the intended goal, which I can assure you works as I tested it myself; hence noticing the disadvantage of this being the loss of drag & drop in File Explorer.
 
Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello Regedit32,

Here is the screen shot of my windows version:

upload_2017-2-22_10-42-3.png


You may also notice below on another screen shot that a Quick Access icon appears on my desktop:

upload_2017-2-22_10-43-30.png


Unfortunately, I do not have a restore point.

What do you suggest? Thank you for your help.

Regards,
 
Joined
Jun 2, 2016
Messages
319
Reaction score
40
Excellent writeup!!!
Got rid of all the Quick Access folders a long time ago but this was still there. It's gone now, thanks.

Why do they make it so difficult to eliminate?
 
Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello Regedit32,

Sorry for delay answer, I was away for a whole week.

I did what you mentioned and download the following update:

Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB3216755)

However, when I click to install it, here is the message I get:

upload_2017-2-28_10-20-45.png


What should I do ?

Thank you.

Regards,
 
Ad

Advertisements

Joined
Feb 16, 2017
Messages
14
Reaction score
1
Hello again Regedit32,

It's ok, I fixed the problem, installed the update and applied the procedure you recommend and everything is at last fine: quick access has disappeared !

Thank you very much for your time and recommendations.

Regards,
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,130
Thanks for the update on your progress.

Glad you finally got what you wanted - just remember it will affect drag and drop in File Explorer so if that gets too annoying change that a0600000 with a0100000 to restore things as they were, or use a restore point which you ought to have now you updated your OS.

Regards,

Regedit32
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top