SOLVED Can't connect to Group Policy Client service

JRT

Joined
Apr 16, 2016
Messages
1
Reaction score
0
Here is the result of my research into this problem as I solved it by reading people's comments on this and other forums.

I updated all 3 of our family laptops to windows 10 and within a few weeks they had all developed this problem. I was therefore in a position to compare what software was on each laptop and try various things.

Symptoms: The Group policy client message was not the only symptom. After this message showed, it was impossible to access the "Update and security" part of the "settings" menu. Also, the policy client message only occurred on startup following a shutdown which was halted by a message saying that a "taskhost" windows was still running an "automatic app update". This was the same on all 3 laptops.

So this error seems linked to the update process not the content of the update itself. The first thing you need to do is get your pc temporarily working properly again. I tried various things but a you-tube video led be to this process which worked every time:
- open a command prompt window as an administrator (right click on the app in the start menu)
- type "netsh" and press enter
- type "winsock reset" and press enter
- restart your computer

At least for me this got rid of the message and made the update menu start working again. I've no idea what this resets but it works and appears to do no harm. HOWEVER, this is only a temporary fix and your issue will come back in a few days!

I read somewhere else that this problem is caused by apps that are installed with "admin" rights trying to update themselves. Chrome is mentioned in particular. I uninstalled chrome and tried to stop other apps from auto-updating. I also suspected MS Office 2007 as this was one of the few apps on all 3 laptops. So I stopped "update" from updating "other window products" under advanced options. I noticed under update history that an update for MS Office 2007 kept failing, so I manually installed that update.

Some of this seemed to make the problem take longer to come back, but it always did at different times on all 3 laptops. I suspect that I didn't manage to stop all apps doing this.

Then a post about the "taskhost" process stopping shutdown led my to the solution. Windows 10 has a special "fast startup option". Basically this seems to make your PC take longer to shutdown but makes the startup a bit quicker. Turn this off! That's it! You find it by:
- Start
- Settings
- System
- Power and sleep
- additional power settings
- click on "choose what the power buttons do"
- scroll down to Shutdown settings
- uncheck the box next to "turn on fast startup"
- click save changes

This worked for all 3 PCs.

My view is that this problem happens when certain apps are trying to update themselves when you turn off your pc. Something conflicts with how the windows "fast startup" process shuts down your pc. This corrupts something about the user accounts and windows update program. But this only happens for certain hardware/software combinations so only a few people get this error.

Hope this helps other frustrated users out there!

I have been fighting this since Sept. 2015! The Geek Squad at Best Buy couldn't resolve it. None of my Tech friends could resolve it and they work the high-tech computer systems in Aerospace. You NAILED IT! My laptop
now installs up dates without issue. It appears my Microsoft Office 2010 was the main program to have conflicting issues. God's blessing - thanks again!
 
Joined
Apr 18, 2016
Messages
1
Reaction score
0
Here is the result of my research into this problem as I solved it by reading people's comments on this and other forums.

I updated all 3 of our family laptops to windows 10 and within a few weeks they had all developed this problem. I was therefore in a position to compare what software was on each laptop and try various things.

Symptoms: The Group policy client message was not the only symptom. After this message showed, it was impossible to access the "Update and security" part of the "settings" menu. Also, the policy client message only occurred on startup following a shutdown which was halted by a message saying that a "taskhost" windows was still running an "automatic app update". This was the same on all 3 laptops.

So this error seems linked to the update process not the content of the update itself. The first thing you need to do is get your pc temporarily working properly again. I tried various things but a you-tube video led be to this process which worked every time:
- open a command prompt window as an administrator (right click on the app in the start menu)
- type "netsh" and press enter
- type "winsock reset" and press enter
- restart your computer

At least for me this got rid of the message and made the update menu start working again. I've no idea what this resets but it works and appears to do no harm. HOWEVER, this is only a temporary fix and your issue will come back in a few days!

I read somewhere else that this problem is caused by apps that are installed with "admin" rights trying to update themselves. Chrome is mentioned in particular. I uninstalled chrome and tried to stop other apps from auto-updating. I also suspected MS Office 2007 as this was one of the few apps on all 3 laptops. So I stopped "update" from updating "other window products" under advanced options. I noticed under update history that an update for MS Office 2007 kept failing, so I manually installed that update.

Some of this seemed to make the problem take longer to come back, but it always did at different times on all 3 laptops. I suspect that I didn't manage to stop all apps doing this.

Then a post about the "taskhost" process stopping shutdown led my to the solution. Windows 10 has a special "fast startup option". Basically this seems to make your PC take longer to shutdown but makes the startup a bit quicker. Turn this off! That's it! You find it by:
- Start
- Settings
- System
- Power and sleep
- additional power settings
- click on "choose what the power buttons do"
- scroll down to Shutdown settings
- uncheck the box next to "turn on fast startup"
- click save changes

This worked for all 3 PCs.

My view is that this problem happens when certain apps are trying to update themselves when you turn off your pc. Something conflicts with how the windows "fast startup" process shuts down your pc. This corrupts something about the user accounts and windows update program. But this only happens for certain hardware/software combinations so only a few people get this error.

Hope this helps other frustrated users out there!

Hi, I have the same frustrating problem, only I no longer seem to have admin access. I am the only user on the machine, I have/had admin privledges, however when I get to > Settings > System > Power and sleep > additional power settings >choose what the power buttons do > scroll down to Shutdown settings : it is all greyed out. The fast box is checked. Scrolling up and selecting the "change the unchangeable settings" leads to a long period of time with a blue rolling mouse wheel and after 5 min (timed it) I get a dialog box to say it wont work.
When I right click startup and select the "command prompt admin" I get nothing except the same blue mouse wheel and dialog box with "wont work"

I can get a netsh and I try to reset winsock but come up with an error message "need to elevate command"

BTW if you have not guessed I'm a win10 nube, What next?
 

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
13,417
Reaction score
2,320
Hi, I have the same frustrating problem, only I no longer seem to have admin access. I am the only user on the machine
Hello CaptainRon and welcome to the forum.
Would you please start your own thread.
Describing your problem as you've done above, as it is distinctly different then most of the other posts in this thread and probably will need a different approach to a resolution.
IN the mean time will you post which version of Windows 10 you are using (windows logo, bottom left of screen on task bar + the "R" key and in the run dialog box type
winver
hit enter or click OK.
AND check settings, update & security and see if there are any windows updates available to you.
 
Joined
Apr 21, 2016
Messages
1
Reaction score
0
I tried every fix I could find for this issue, to no avail. I finally found a little post concerning Google Chrome. It said to uninstall Chrome and reinstall. That seems to have worked! I haven't had a problem in three days of operation.
 
Joined
Apr 24, 2016
Messages
1
Reaction score
0
Here is the result of my research into this problem as I solved it by reading people's comments on this and other forums.

I updated all 3 of our family laptops to windows 10 and within a few weeks they had all developed this problem. I was therefore in a position to compare what software was on each laptop and try various things.

Symptoms: The Group policy client message was not the only symptom. After this message showed, it was impossible to access the "Update and security" part of the "settings" menu. Also, the policy client message only occurred on startup following a shutdown which was halted by a message saying that a "taskhost" windows was still running an "automatic app update". This was the same on all 3 laptops.

So this error seems linked to the update process not the content of the update itself. The first thing you need to do is get your pc temporarily working properly again. I tried various things but a you-tube video led be to this process which worked every time:
- open a command prompt window as an administrator (right click on the app in the start menu)
- type "netsh" and press enter
- type "winsock reset" and press enter
- restart your computer

At least for me this got rid of the message and made the update menu start working again. I've no idea what this resets but it works and appears to do no harm. HOWEVER, this is only a temporary fix and your issue will come back in a few days!

I read somewhere else that this problem is caused by apps that are installed with "admin" rights trying to update themselves. Chrome is mentioned in particular. I uninstalled chrome and tried to stop other apps from auto-updating. I also suspected MS Office 2007 as this was one of the few apps on all 3 laptops. So I stopped "update" from updating "other window products" under advanced options. I noticed under update history that an update for MS Office 2007 kept failing, so I manually installed that update.

Some of this seemed to make the problem take longer to come back, but it always did at different times on all 3 laptops. I suspect that I didn't manage to stop all apps doing this.

Then a post about the "taskhost" process stopping shutdown led my to the solution. Windows 10 has a special "fast startup option". Basically this seems to make your PC take longer to shutdown but makes the startup a bit quicker. Turn this off! That's it! You find it by:
- Start
- Settings
- System
- Power and sleep
- additional power settings
- click on "choose what the power buttons do"
- scroll down to Shutdown settings
- uncheck the box next to "turn on fast startup"
- click save changes

This worked for all 3 PCs.

My view is that this problem happens when certain apps are trying to update themselves when you turn off your pc. Something conflicts with how the windows "fast startup" process shuts down your pc. This corrupts something about the user accounts and windows update program. But this only happens for certain hardware/software combinations so only a few people get this error.

Hope this helps other frustrated users out there!

Hi mate, a quick message to thank you so much for your thread response. I ordered a new Windows machine for my girlfriend's father. I then became chief IT support by default, haha.

After countless visits and phone troubleshooting sessions including Windows reinstalls, Office reinstalls, driver updates and phone calls to Lenovo, I was at my wits end...

I came across your solution for disabling fast startup and touch wood, the computer has not skipped a beat for two weeks now. Looks like it has worked a treat.

Thank you again as you must have saved myself and countless others many hours of time and frustration.

Cheers,
Jamie
 
Joined
Apr 13, 2016
Messages
5
Reaction score
0
Hello all, I have done the command prompt run as administrator and have typed in netsh then winsock reset. This fixes the problem temporary but it pops back up. Does anyone know how to make it go away permanently? Much help needed thanks a lot.
 
Joined
Apr 27, 2016
Messages
1
Reaction score
0
Hi, I have the same frustrating problem, only I no longer seem to have admin access. I am the only user on the machine, I have/had admin privledges, however when I get to > Settings > System > Power and sleep > additional power settings >choose what the power buttons do > scroll down to Shutdown settings : it is all greyed out. The fast box is checked. Scrolling up and selecting the "change the unchangeable settings" leads to a long period of time with a blue rolling mouse wheel and after 5 min (timed it) I get a dialog box to say it wont work.
When I right click startup and select the "command prompt admin" I get nothing except the same blue mouse wheel and dialog box with "wont work"

I can get a netsh and I try to reset winsock but come up with an error message "need to elevate command"

BTW if you have not guessed I'm a win10 nube, What next?

Hi CaptainRon,

Have you been able to fix this? I looked to see if you had started another post but I couldn't find anything.

I had the exact same issue as you and I followed Jayasri's suggestion to restart and then try it again. This time when I clicked on "change the unchangeable settings" it opened up and displayed as black and I was able to uncheck the fast update setting. I restarted my laptop after that and it was already moving faster. I haven't opened up Chrome yet to see it that's working properly, I'm replying from Firefox right now. I hope you were able to get it fixed.
 
Joined
Apr 13, 2016
Messages
5
Reaction score
0
Any help please??? I keep getting the message even though after command run as administrator and then netsh winsock reset. I keep getting the same pop up. Cannot connect to group policy client service. Please anyone
 
Joined
May 8, 2016
Messages
1
Reaction score
0
Turn off fast start did the trick, I'll follow up if it fails again. I was testing a new interactive web page that used lots of video back and forth and lots of remote control commands. 3 sesions and Chrome was crippled. It seems window smith was onto it. To me the issue is quite complex and there may be many causes so the solution is how to not react badly to what seems to be an amorphous irritation. But these are just machines.
 
Joined
Apr 13, 2016
Messages
5
Reaction score
0
Turn off fast start did the trick, I'll follow up if it fails again. I was testing a new interactive web page that used lots of video back and forth and lots of remote control commands. 3 sesions and Chrome was crippled. It seems window smith was onto it. To me the issue is quite complex and there may be many causes so the solution is how to not react badly to what seems to be an amorphous irritation. But these are just machines.

So far so good. I did it three days ago and so far it's worked, thanks.
 
Joined
May 11, 2016
Messages
2
Reaction score
0
Hi CaptainRon,

Have you been able to fix this? I looked to see if you had started another post but I couldn't find anything.

I had the exact same issue as you and I followed Jayasri's suggestion to restart and then try it again. This time when I clicked on "change the unchangeable settings" it opened up and displayed as black and I was able to uncheck the fast update setting. I restarted my laptop after that and it was already moving faster. I haven't opened up Chrome yet to see it that's working properly, I'm replying from Firefox right now. I hope you were able to get it fixed.


I'm having the same problem as CaptainRon. Tried rebooting computer but still cant uncheck fast update. I seem to be in a real catch 22. Computer going so slow that its not letting me make the changes.
 

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
13,417
Reaction score
2,320
I'm having the same problem as CaptainRon. Tried rebooting computer but still cant uncheck fast update. I seem to be in a real catch 22. Computer going so slow that its not letting me make the changes.
right click the start button and choose
command prompt (admin) and in the command prompt window type
powercfg.exe /hibernate off
hit enter
that I believe should accomplish the same thing
IF not just redo the command prompt to say
powercfg.exe /hibernate on
hit enter
 
Joined
May 11, 2016
Messages
2
Reaction score
0
right click the start button and choose
command prompt (admin) and in the command prompt window type
powercfg.exe /hibernate off
hit enter
that I believe should accomplish the same thing
IF not just redo the command prompt to say
powercfg.exe /hibernate on
hit enter
I seem to have it sorted. May just be luck. I figured that if automatic downloads are the problem why not go off line. I unplugged the computer from the internet (I still use a wire connection). It may have been coincidence but I could then get admin access and make the changes and disable fast startup. I spent hours last night unable to do this wile still online. So far so good, back online, and computer is ticking along nicely. Its only been 3hrs of use so far, fingers crossed.
 
Joined
May 11, 2016
Messages
1
Reaction score
0
Here is the result of my research into this problem as I solved it by reading people's comments on this and other forums.

I updated all 3 of our family laptops to windows 10 and within a few weeks they had all developed this problem. I was therefore in a position to compare what software was on each laptop and try various things.

Symptoms: The Group policy client message was not the only symptom. After this message showed, it was impossible to access the "Update and security" part of the "settings" menu. Also, the policy client message only occurred on startup following a shutdown which was halted by a message saying that a "taskhost" windows was still running an "automatic app update". This was the same on all 3 laptops.

So this error seems linked to the update process not the content of the update itself. The first thing you need to do is get your pc temporarily working properly again. I tried various things but a you-tube video led be to this process which worked every time:
- open a command prompt window as an administrator (right click on the app in the start menu)
- type "netsh" and press enter
- type "winsock reset" and press enter
- restart your computer

At least for me this got rid of the message and made the update menu start working again. I've no idea what this resets but it works and appears to do no harm. HOWEVER, this is only a temporary fix and your issue will come back in a few days!

I read somewhere else that this problem is caused by apps that are installed with "admin" rights trying to update themselves. Chrome is mentioned in particular. I uninstalled chrome and tried to stop other apps from auto-updating. I also suspected MS Office 2007 as this was one of the few apps on all 3 laptops. So I stopped "update" from updating "other window products" under advanced options. I noticed under update history that an update for MS Office 2007 kept failing, so I manually installed that update.

Some of this seemed to make the problem take longer to come back, but it always did at different times on all 3 laptops. I suspect that I didn't manage to stop all apps doing this.

Then a post about the "taskhost" process stopping shutdown led my to the solution. Windows 10 has a special "fast startup option". Basically this seems to make your PC take longer to shutdown but makes the startup a bit quicker. Turn this off! That's it! You find it by:
- Start
- Settings
- System
- Power and sleep
- additional power settings
- click on "choose what the power buttons do"
- scroll down to Shutdown settings
- uncheck the box next to "turn on fast startup"
- click save changes

This worked for all 3 PCs.

My view is that this problem happens when certain apps are trying to update themselves when you turn off your pc. Something conflicts with how the windows "fast startup" process shuts down your pc. This corrupts something about the user accounts and windows update program. But this only happens for certain hardware/software combinations so only a few people get this error.

Hope this helps other frustrated users out there!


Thanks so much! Was scared to death when I couldn't log into my user account. This fixed it.
 
Joined
May 12, 2016
Messages
1
Reaction score
0
Thank you Windowsmith. I've had this problem off and on for months. Almost always resolved by doing a restore. BUT as you and others state - it will eventually return. I also noticed as you did that it was "impossible to access the "Update and security" part of the "settings" menu". I also experienced another characteristic which I'm sure is related - File Explorer failed to respond when "exploring" personal files I store in the second partition (D) of my hard drive. In fact it was this problem that first presented itself and I've only just realised it seems to be related. I've spent ages researching the problem with File Explorer (on some forums it's also called Windows Explorer) without success. I followed your guidance re running instructions at Command Prompt and then restarting. Immediately access to "update and security" settings became available and the problem with File Explorer disappeared. At last, thanks to you I'm sure the problem is now permanently solved.
 
Joined
May 16, 2016
Messages
2
Reaction score
1
Thank you windowsmith!! This problem has plagued my PC for the past 2 years (from Windows 8 and up to Windows10's newest updated version). In the past reinstall has been the only solution that actually worked. Your posted solution to this is a lifesaver! Thank you!!
 
Joined
May 16, 2016
Messages
2
Reaction score
1
Thank you Windowsmith. I've had this problem off and on for months. Almost always resolved by doing a restore. BUT as you and others state - it will eventually return. I also noticed as you did that it was "impossible to access the "Update and security" part of the "settings" menu". I also experienced another characteristic which I'm sure is related - File Explorer failed to respond when "exploring" personal files I store in the second partition (D) of my hard drive. In fact it was this problem that first presented itself and I've only just realised it seems to be related. I've spent ages researching the problem with File Explorer (on some forums it's also called Windows Explorer) without success. I followed your guidance re running instructions at Command Prompt and then restarting. Immediately access to "update and security" settings became available and the problem with File Explorer disappeared. At last, thanks to you I'm sure the problem is now permanently solved.

Bikernorm, windowsmith's Command Prompt solution is only a temporary fix for this problem. I recommend you also follow windowsmith's other (permanent) recommend solution as a permanent fix for this problem. Please refer to windowsmith's long post above. Herewith follows windowsmith's permanent fix for this problem:
Windows 10 has a special "fast startup option". Basically this seems to make your PC take longer to shutdown but makes the startup a bit quicker. Turn this off! That's it! You find it by:
- Start
- Settings
- System
- Power and sleep
- additional power settings
- click on "choose what the power buttons do"
- click on "change settings that are unavailable"
- scroll down to Shutdown settings
- uncheck the box next to "turn on fast startup"
- click save changes
- shut down your pc (this shut down will take much longer than usual), and if prompted don't click on "shut down anyway
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top