SOLVED Windows 10 - Does not keep correct time


Joined
Jul 22, 2015
Messages
173
Reaction score
15
Good day,
My computer cannot keep the correct time. It is usually three hours behind. (For example, at 7 A.M. the time shown is 4 A.M.
If I reset the clock to the correct time, it maintains that correct time until I shut down the computer. On the next startup, the time is incorrect again.
I have searched the Internet and attempted many of the suggested solutions but they do not help. I have even gone so far as to reinstall Windows 10.
I am using a dual load - Windows 10 and Ubuntu. Ubuntu has no problem with the time.

I have the following settings at this time, but have tried numerous other settings.
Country or region – Israel
Language – English and Hebrew
Set time automatically – ON
Time zone – UTC + 02:00 Jerusalem
Adjust for daylight saving time automatically - ON

Specs:
Dell Inspiron 17" 5721
BIOS Mode - Legacy
Windows 10 - x64 and Ubuntu 16.04
Intel core i7
Memory - 8 GB

Suggestions ?
Thank you
 
Ad

Advertisements

Joined
Aug 9, 2015
Messages
65
Reaction score
10
sounds like your cmos battery has run out and needs changing.
 
Joined
Jul 22, 2015
Messages
173
Reaction score
15
Are you suggesting the cmos battery ran out just for Windows 10 but is functional for Ubuntu? Huh?
 

Ian

Administrator
Joined
Oct 27, 2013
Messages
1,681
Reaction score
587
You mention that "Set time automatically" is on, can you also make sure that "Set time zone automatically" is turned off - it may be that it is incorrectly detecting your location and overriding your chosen time zone.

Capture.PNG
 
Joined
Feb 18, 2016
Messages
2,834
Reaction score
624
Looking at the initial post bari is correct. A clock not keeping time an indication the cmos battery requires replacing. In your second post you say it's OK in Ubuntu, and looses time with Win 10? follow Ian's suggestion.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,129
The only other thing I can think of is that somehow your system has forgotten to sync to an Internet Time Server.

You could check that by:
  • Right-clicking on Start
  • Left-clicking on Control Panel
  • In the Control Panel window at top right click View by and choose large icons
  • Left-click on Date and Time
  • Left-click on the Internet Time tab
  • Left-click the Change settings button

    Your settings ought to look like this sample image:

    its.png


    You can use the drop arrow to select a different Server then click the Update now button

    Note: If your current time is a long way out, when you click the Update now button you may see an error message appear. If that happens reselect a Server and repeat process until it reports the setting was changed successfully. It may take a few attempts.
 
Ad

Advertisements

Joined
Jul 22, 2015
Messages
173
Reaction score
15
@ Norton - I stated in the original post that the clock time works with no problem in Ubuntu but is off, usually by three hours in Windows 10. It is to my understanding that the cmos battery is a BIOS thing and should work for both.
 
Joined
Jul 22, 2015
Messages
173
Reaction score
15
@ Regedit32 - I have two choices for synchronizing the clock. (1) time.windows.com and (2) time.nist.gov. I have switched these two choices a number of times with no obvious change. When I click on "Update now", the time changes to the correct time on either choice.
 
Joined
Jul 22, 2015
Messages
173
Reaction score
15
@ ian - I have tried both ways, but usually I set it to my time zone manually. I also have activated and deactivated "Automatically adjust clock for Daylight Saving Time", with no change.
 
Joined
Feb 18, 2016
Messages
2,834
Reaction score
624
This gets complicated. Maybe Ubuntu and Microsoft handle the IDT or PST differently? It seems there has always been some confusion over the DST. MS gave up on the uncertainty of the dates for DST and changed IDT, to GMT+2hrs. As a suggestion, try deselecting "Adjust DST automatically" in Win 10 settings.

https://en.wikipedia.org/wiki/Israel_Summer_Time
 
Last edited:

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,129
@ Regedit32 - I have two choices for synchronizing the clock. (1) time.windows.com and (2) time.nist.gov. I have switched these two choices a number of times with no obvious change. When I click on "Update now", the time changes to the correct time on either choice.
Hi if resetting the Internet Time Server is having no noticeable affect, and you are certain your CMOS battery is not too old and thus possibly almost flat, then its possible the Windows Time Service is not running.

You can verify that by:
  • Right-clicking on Start then left-clicking on Run
  • In the Run dialog type services.msc then click OK
  • Scroll the list of Services to locate Windows Time
  • Check the Startup Type column to check it says Automatic

    If it does not say Automatic there then right-click on Windows Time and select Properties

    In the window that opens click drop arrow next to Startup type and select Automatic then click OK
 
Ad

Advertisements

Joined
Jun 25, 2015
Messages
88
Reaction score
7
One common reason for an incorrect date and time is a failing CMOS battery. Sometimes Malware has also been reported as the reason for incorrect time results.
 
Joined
Jul 22, 2015
Messages
173
Reaction score
15
@ davehc - You might have something there. I will check and get back to you. I will uninstall Ubuntu and see what happens with Windows 10 running solo. Have to go to work now, so it will be tonight or tomorrow morning.
I really appreciate all the replies from everyone.
 
Joined
Nov 19, 2013
Messages
5,457
Reaction score
1,111
Hope it works. Truth is I have only just started experimenting with dual booting Linux. I am in the same situation. I live in Denmark, but, not being 100% familiar with the language, I prefer to associate myself with the UK. I ran into the same problem as yourself and got it sorted (I think) by trying a few things from that link.
 
Joined
Jul 22, 2015
Messages
173
Reaction score
15
Arrrrggggh! No luck! I ran Windows 10 by itself, (no dual boot)), and the darn clock is still wrong. I should mention again, that once I set the clock to the correct time, and do not turn off my compute, the time remains correct. I am on the verge of giving up.
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
5,457
Reaction score
1,111
I would be inclined to agree with the comment regarding a battery replacement, but for the fact that you time doesn't vary randomly but to a fixed (3HRs?) error.
 
Joined
Feb 18, 2016
Messages
2,834
Reaction score
624
MORE INFORMATION
If your computer loses time, use the Date/Time tool to set the correct time:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Date/Time.
  3. On the Date & Time tab, configure the correct time, and then click OK.
To determine if the time loss is a result of a weak computer battery:
  1. Click Start, point to Programs, and then click MS-DOS Prompt.
  2. At the command prompt, type time, and then press ENTER.
  3. Compare this time with the time that is reported by the clock on the taskbar.
  4. Type exit, and then press ENTER.
If the computer's time and the time on the clock are different, the computer's battery may be too weak to keep accurate time, and it should be replaced. For information about how to replace the battery, refer to the documentation included with your computer.

NOTE: This problem does not affect the clock in your computer's CMOS.

https://support.microsoft.com/en-us/kb/189706
 

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
13,079
Reaction score
2,225
My computer cannot keep the correct time. It is usually three hours behind. (For example, at 7 A.M. the time shown is 4 A.M.
If I reset the clock to the correct time, it maintains that correct time until I shut down the computer. On the next startup, the time is incorrect again.
When the computer first starts up, it reads the time from the System Setup Utility (BIOS) maintained by the CMOS Real Time Clock dependent on the motherboard battery.

Why not just put a new battery in and see if the problem is resolved

Most computers built in the last few years, even when turned off, receive enough power from an AC source through the power supply to maintain the system clock even with a bad battery, so.....
Unless this is a very old computer, or if you are turning it off and then disconnecting it from the AC power source by unplugging it or flipping the switch on a surge protector, then if your problem persists even after changing the motherboard battery, then you have a bad capacitor in your power supply which is causing the problem.
 
Ad

Advertisements

Joined
Oct 13, 2015
Messages
330
Reaction score
46
Also check the time and date in the BIOS are correct. You have already checked in Windows 10.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top